WebFaction
Community site: login faq
0
1

I want to create a question-answer site for students using OSQA for italian students. I installed OSQA and it works fine.
I have created several subdomains (like history.university.it, english.university.it, math.university.it, etc) and i added to al this websites the osqa web app. The problem is that when I open a question, for example in history.university.it, i see this question in all the other websites, the same question.

So I tried to following this guide but it is not clear and I failed, i get 500 Internal Server Error.
I tried to ask the question at osqa.com, but I have not received any replies. I use the Webfaction server so I decided to ask here.

Thank you for taking the time to look at my question, and I hope to receive a good response.
Thank you very much! ;)


Edit:

What I did:

  • I created a copy of the files settings.py and settings_local.py for the new site in the same directory as the main osqa site and I've renamed them in settings_math.py and settings_local_math.py and I edited them accordingly.

  • In my osqa.wsgi I specified sys.path for the new settings. Below the
    os.environ['DJANGO_SETTINGS_MODULE'] = 'osqa.settings'
    i added
    os.environ['DJANGO_SETTINGS_MODULE'] = 'osqa.settings_math'

  • Now i edited the settings_ math.py and under the
    #User settings i added
    from settings_local_math import *

  • I created database and filled settings_local_math.py accordingly and I added APP_URL (i.e. http://math.university.it/)

  • I run python2.7 manage.py syncdb --settings=settings_math (I don't get any error here). Then I restart apache with ~/webapps/osqa_server/apache2/bin/restart

  • Finally from the browser I enter the website address and I get 500 Internal Server Error.

asked 11 Aug '12, 18:46

stakkit
212
accept rate: 0%

edited 11 Aug '12, 22:04

I think we'll need to investigate a bit deeper. Can you please log a support ticket with all this info from your WebFaction control panel?

(11 Aug '12, 22:40) waynek

Ok! Thank you!

(12 Aug '12, 11:05) stakkit

Could you tell us how far you got through the instructions, with exactly what you did? Then we can try to help you along.

Thanks,

permanent link

answered 11 Aug '12, 19:07

waynek
4254
accept rate: 27%

Thank you waynek! I edited the question and I added what I did.

(11 Aug '12, 21:58) stakkit
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×909
×113
×43
×13
×3

question asked: 11 Aug '12, 18:46

question was seen: 3,133 times

last updated: 12 Aug '12, 11:05

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM