WebFaction
Community site: login faq

I have installed ghc-7.4.2 as per the instructions posted in another question, but when I try to build Haskell Platform 2012.2.0.0 ./configure fails with:

...
checking for library containing gluNewQuadric... -lGLU
checking GL/glut.h usability... no
checking GL/glut.h presence... no
checking for GL/glut.h... no
configure: error: The GLUT C library is required

How should I proceed?

asked 01 Sep '12, 12:22

Maciek Makowski
324
accept rate: 0%


Check the documentation on building from source, specifically the Troubleshooting section which covers CPPFLAGS, LDFLAGS, and LD_LIBRARY_PATH. Setting these variables typically solve issues with missing custom libraries. You will also want to read './configure --help'.

permanent link

answered 01 Sep '12, 17:27

johns
5.4k412
accept rate: 23%

Thanks for responding; I managed to solve my actual problem (installing gitit) without setting up Haskell Platform, but I'll give your suggestions a go in case I need it again.

(02 Sep '12, 14:38) Maciek Makowski
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×7
×3
×1

question asked: 01 Sep '12, 12:22

question was seen: 2,984 times

last updated: 02 Sep '12, 14:38

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM