WebFaction
Community site: login faq

Hi, I am trying to install my drupal project from my local system to the server. I have created the database & it's running fine. I changed the $db_url in settings.php & given the required permission to the default directory. But when I try to open the site then the message is coming "Not Found. The requested URL was not found on this server". I have also copied the .htaccess file. The clean URL is also disabled still Not Found message is coming. I am attaching the .htaccess file also for reference. Please help me I am screwed & nothing seems working for me. I would like to inform one thing also the same thing I am doing on my local system is working but when I am doing the same copy of my local system drupal site to another server it is showing Not Found. Thanks in advance. here is my .htaccess file contents. I am using apache server


Apache/PHP/Drupal settings:

Protect files and directories from prying eyes.

<filesmatch "klzzwxh:0000(engine|inc|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl(klzzwxh:0001php)?|xtmpl|svn-base)$|^(code-styleklzzwxh:0002pl|entries.*|repository|root|tag|template|all-wcprops|entries|format)$"=""> Order allow,deny </filesmatch>

Don't show directory listings for URLs which map to a directory.

Options -Indexes

Follow symbolic links in this directory.

Options +FollowSymLinks

Make Drupal handle any 404 errors.

ErrorDocument 404 /index.php

Force simple error message for requests for non-existent favicon.ico.

<files favicon.ico=""> # There is no end quote below, for compatibility with Apache 1.3. ErrorDocument 404 "The requested file favicon.ico was not found. </files>

Set the default handler.

DirectoryIndex index.php kjsfgbvytuilwecftuwel

Override PHP settings. More in sites/default/settings.php

but the following cannot be changed at runtime.

PHP 4, Apache 1.

<ifmodule mod_php4.c=""> php_value magic_quotes_gpc
php_value register_globals 0 php_value session.auto_start 0 php_value mbstring.http_input pass php_value mbstring.http_output pass php_value mbstring.encoding_translation 0 </ifmodule>

PHP 4, Apache 2.

<ifmodule sapi_apache2.c=""> php_value magic_quotes_gpc 0 php_value register_globals 0 php_value session.auto_start 0 php_value mbstring.http_input pass php_value mbstring.http_output pass php_value mbstring.encoding_translation 0 </ifmodule>

PHP 5, Apache 1 and 2.

<ifmodule mod_php5.c=""> php_value magic_quotes_gpc 0 php_value register_globals 0 php_value session.auto_start 0 php_value mbstring.http_input pass php_value mbstring.http_output pass php_value mbstring.encoding_translation 0 </ifmodule>

Requires mod_expires to be enabled.

<ifmodule mod_expires.c=""> # Enable expirations. ExpiresActive On

# Cache all files for 2 weeks after access (A). ExpiresDefault A1209600

<filesmatch klzzwxh:0015php$=""> # Do not allow PHP scripts to be cached unless they explicitly send cache # headers themselves. Otherwise all scripts would have to overwrite the # headers set by mod_expires if they want another caching behavior. This may # fail if an error occurs early in the bootstrap process, and it may cause # problems if a non-Drupal PHP file is installed in a subdirectory. ExpiresActive Off </filesmatch> </ifmodule>

Various rewrite rules.

<ifmodule mod_rewrite.c=""> RewriteEngine on

# If your site can be accessed both with and without the 'www.' prefix, you # can use one of the following settings to redirect users to your preferred # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option: # # To redirect all users to access the site WITH the 'www.' prefix, # (http://example.com/... will be redirected to http://www.example.com/...) # adapt and uncomment the following: # RewriteCond %{HTTP_HOST} ^example.com$ [NC] # RewriteRule ^(.)$ http://www.example.com/$1 [L,R=301] # # To redirect all users to access the site WITHOUT the 'www.' prefix, # (http://www.example.com/... will be redirected to http://example.com/...) # uncomment and adapt the following: # RewriteCond %{HTTP_HOST} ^www.example.com$ [NC] # RewriteRule ^(.)$ http://example.com/$1 [L,R=301]

# Modify the RewriteBase if you are using Drupal in a subdirectory or in a # VirtualDocumentRoot and the rewrite rules are not working properly. # For example if your site is at http://example.com/drupal uncomment and # modify the following line: # RewriteBase /drupal # # If your site is running in a VirtualDocumentRoot at http://example.com/, # uncomment the following line: # RewriteBase /

# Rewrite URLs of the form 'x' to the form 'index.php?q=x'. RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_URI} !=/favicon.ico RewriteRule ^(.*)$ index.php?q=$1 [L,QSA] </ifmodule>

$Id$


asked 19 Sep '12, 07:19

UKS
3223
accept rate: 0%


It would be hard to determine what's wrong with your setup without looking at your configuration. Could you open a ticket at our support site?

permanent link

answered 19 Sep '12, 07:29

todork
1.2k5
accept rate: 34%

Thanks for replying todork. I am going to open the ticket

(19 Sep '12, 08:10) UKS
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×226
×33

question asked: 19 Sep '12, 07:19

question was seen: 17,628 times

last updated: 19 Sep '12, 08:10

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM