WebFaction
Community site: login faq

Hello ppl, I'm struggling with getting my first deploy to work and would very much appreciate any help.

I followed the docs and the result is a 403 from nginx.

I'm running: Rails 3.2.3 (nginx 1.0.10/Passenger 3.0.11/Ruby 1.9.3)

If I look in the releases folder on the server I can see files created for every time I ran the deploy-script. But I can't find the code anywhere. :/

I have changed the config in nginx/conf/nginx.conf so that root points to my app public dir such: /home/konscia/webapps/hhg/current/public;

How would I proceed in debugging this?

<3

asked 09 Dec '12, 13:17

Abeansits
111
accept rate: 0%

Be sure that your path is to the correct public location. If you are not sure, Please open a ticket at our support site, and we'll help you find a solution.

(09 Dec '12, 14:08) timg ♦♦

By path you mean the root variable in ngingx-conf? It points to: /home/USERNAME/webapps/APPNAME/current That is correct right?

(11 Dec '12, 15:59) Abeansits

That should be right. There is also more info on Troubleshooting and Debugging in the docs.

(12 Dec '12, 00:32) johns

Hi @johns, I am experiencing the same problem, after a server migrate. Yet imho the problem is not rails related, I think, because I see nothing in my rails log. If passenger was unable to start my rails process, I would see the passenger error page. So I am presuming (not sure), that it is a nginx problem? Or maybe passenger is not starting at all?

(13 Feb '13, 19:05) nathanvda

@nathanvda - the problem is bad permissions on your app's tmp subdirectory.

I just fixed one of your sites by running "chmod -R 700 ~/webapps/name_of_the_app/tmp" and then restarting the app.

If you're seeing this problem on other Rails sites/apps, then do the same thing on those.

(13 Feb '13, 19:19) seanf
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×186
×32
×20
×12

question asked: 09 Dec '12, 13:17

question was seen: 3,094 times

last updated: 13 Feb '13, 19:19

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM