WebFaction
Community site: login faq

I have my static app called 'iniyaval' in this location /home/iniyaval/webapps/iniyaval

But I wish to maintain my source in this location /home/iniyaval/myRepositories/iniyaval/iniyavalWeb

So what I want is, The app iniyaval should not be a folder instead I want it as softlink. I want this below effect. Is that possible?

lrwxrwxrwx 1 iniyaval iniyaval 31 Jan 31 11:18 iniyaval -> /home/iniyaval/myRepositories/iniyaval/iniyavalWeb

asked 31 Jan '13, 20:58

nehemiah
325
accept rate: 0%


It sounds like what you're looking for is a "Symbolic Link to Static/CGI/PHP" application, but this assumes that ~/myRepositories/iniyaval/iniyavalWeb is a CGI/PHP application. You would use the full path ("/home/iniyaval/myRepositories/iniyaval/iniyavalWeb") in the extra_info field when creating it.

If it's raw static files which you want to serve with the front-end Nginx server, you can use a "Symbolic Link to Static-Only" application instead. This would have the same extra_info as above. Note that you can't use .htaccess files with this application type.

Finally, if it's an application which runs on a port, like Django, you would create a "Custom Application (listening on port)" and then configure your Django application's Apache instance to listen on the localhost port assigned by that application. As long as Apache's listening on the right port, it doesn't matter where the actual Django files are, so they can be anywhere in your home directory (or even under one of your separate SSH users).

Hope that helps!

permanent link

answered 31 Jan '13, 21:11

ryans ♦♦
5.0k93160
accept rate: 43%

That was a great answer which worked.

Got a question, What did you mean by "Note that you can't use .htaccess files with this application type." I created a .htaccess file contains as

[iniyaval@web322 iniyavalWeb]$ cat .htaccess

Options -Indexes

And successfully able to control the user from seeing directory listing.

(05 Feb '13, 08:32) nehemiah

The .htaccess restriction is for "Symbolic link to static-only" apps.

You're using a "Symbolic link to static/cgi/php54" app , which does permit the use of .htaccess files.

(05 Feb '13, 12:00) seanf
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×54
×17

question asked: 31 Jan '13, 20:58

question was seen: 4,539 times

last updated: 05 Feb '13, 12:00

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM