WebFaction
Community site: login faq

I'm trying Git for the first time. I've set up the app and Website record on the control panel, and SSH'd in to git init --bare dev.git inside the /webapps/git_app/repos/ folder.

dev.git is in there, and I'm trying to push the material on my local computer up to the git repository.

I'm trying git push --mirror ssh://username@username.webfactional.com/webapps/git_app/repos/dev.git

...but I get the following error message:

"fatal: webapps/git_app/repos/dev.git does not appear to be a git repository."

I'm admittedly very new to this, but I can't figure out what I'm doing wrong.

asked 04 Feb '13, 18:03

mattshepherd's gravatar image

mattshepherd
452930
accept rate: 0%


Try appending '/home/username/' before 'webapps/git_app/...'

SSH expects the full file-system path.

permanent link

answered 04 Feb '13, 20:27

johns's gravatar image

johns ♦♦
4.8k29
accept rate: 23%

It seemed to work briefly, but now that I'm trying to restart the process, it doesn't --

git clone ssh://username@username.webfactional.com:home/username/webapps/git_app/repos/dev.git Cloning into 'dev'... ssh: Could not resolve hostname mattshepherd.webfactional.com:home: Name or service not known fatal: The remote end hung up unexpectedly

(07 Feb '13, 17:28) mattshepherd mattshepherd's gravatar image

You're missing the leading slash before "home":

git clone ssh://username@username.webfactional.com:/home/username/webapps/git_app/repos/dev.git

Also, be sure that you are replacing "username" with your actual user name.

(07 Feb '13, 17:33) seanf ♦♦ seanf's gravatar image

Well, at least I got the "username" part right.

Added the leading slash, still no joy.

Changed tactics and tried it using git clone and the Web site record instead, and after being prompted to run git update-server-info, and doing so, git clone started working with the Web name as opposed to the SSH string.

(07 Feb '13, 18:03) mattshepherd mattshepherd's gravatar image

But push origin master still gives me

error: Cannot access URL http://git.fictionfights.com/repos/dev.git/, return code 22 fatal: git-http-push failed

I think I need to nuke this thing from space and start over with a Git manual that walks me through setting the whole thing up again.

(07 Feb '13, 18:11) mattshepherd mattshepherd's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×107
×106
×101
×11

question asked: 04 Feb '13, 18:03

question was seen: 9,629 times

last updated: 07 Feb '13, 18:11

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2016 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM