WebFaction
Community site: login faq

Hi,

I am installing pinax. I initially applied settings described in http://code.pinaxproject.com/wiki/DetailedPinaxWebfaction/. Currently my application throws error: "ImproperlyConfigured: Error importing middleware django_openid.consumer: "No module named groups.base"

I am using python 2.6, Django 1.0.4 and pinax 0.7.3

In my settings.py, I was getting "No module named" errors for pinax modules, and I read that this was about a path hack being removed and INSTALLED_APPS in settings.py should declare modules as pinax.apps.x. Having done so, "No module named" errors were resolved however even though I declare 'pinax.apps.groups' and 'pinax.apps.groups.base', I still get "No module named groups.base"

Here is my error log:

[Tue Dec 28 08:07:40 2010] [error] [client 127.0.0.1] mod_wsgi (pid=316): Exception occurred processing WSGI script '/home/x/webapps/x/mainsite.wsgi'. [Tue Dec 28 08:07:40 2010] [error] [client 127.0.0.1] Traceback (most recent call last): [Tue Dec 28 08:07:40 2010] [error] [client 127.0.0.1] File "/home/x/envs/pinax-env/lib/python2.6/site-packages/django/core/handlers/wsgi.py", line 230, in call [Tue Dec 28 08:07:40 2010] [error] [client 127.0.0.1] self.load_middleware() [Tue Dec 28 08:07:40 2010] [error] [client 127.0.0.1] File "/home/x/envs/pinax-env/lib/python2.6/site-packages/django/core/handlers/base.py", line 41, in load_middleware [Tue Dec 28 08:07:40 2010] [error] [client 127.0.0.1] raise exceptions.ImproperlyConfigured, 'Error importing middleware %s: "%s"' % (mw_module, e) [Tue Dec 28 08:07:40 2010] [error] [client 127.0.0.1] ImproperlyConfigured: Error importing middleware django_openid.consumer: "No module named groups.base"

I would appreciate any help, kind regards.

asked 28 Dec '10, 07:14

erenay's gravatar image

erenay
6113
accept rate: 0%

edited 29 Dec '10, 07:34


Apparentlyl, the directory where the "groups" module resides is not present on your Python path. Please try adding this directory to the Python path, by editing your .wsgi file, as described at http://docs.webfaction.com/software/python.html#adding-to-sys-path-from-myproject-wsgi

permanent link

answered 28 Dec '10, 07:35

tie's gravatar image

tie
1.4k13
accept rate: 44%

Thanks tie, I added the required directories and the application now shows up however it doesn't display images as shown below:

alt text

Any idea which settings I need to update to fix this problem?

permanent link

answered 29 Dec '10, 07:27

erenay's gravatar image

erenay
6113
accept rate: 0%

You probably need to update the MEDIA_URL value in your settings.py (you can read more about this setting at http://docs.djangoproject.com/en/dev/ref/settings/#media-url)

(29 Dec '10, 08:01) tie tie's gravatar image

it was the SERVE_MEDIA variable in settings.py. I changed it back to DEBUG back from False. Thank you.

(29 Dec '10, 08:34) erenay erenay's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×852
×42
×13

question asked: 28 Dec '10, 07:14

question was seen: 11,082 times

last updated: 29 Dec '10, 08:34

O
WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2016 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
SUITE 1, FIRST FLOOR, 41 CHALTON STREET, LONDON NW1 1JD, UNITED KINGDOM