WebFaction
Community site: login faq

I installed the 'Wordpress' app, and then uploaded my themes, plugins, and content to wp-content. Wordpress loads fine, but when I try to upload an image to a new or existing post, I get an internal server error. After checking the logs, here's what I see:

[Thu Dec 30 22:59:04 2010] [error] [client my_ip_address] Premature end of script headers: php52.cgi, referer: http://appbistro.webfactional.com/wp-admin/edit.php?post_status=trash&post_type=post

I Googled this error to no avail...

I also noticed an internal server error when I try to delete a post...

I have tried chmod'ing the upload folder (and all subfolders) to 777 - no luck.

Any ideas?

asked 31 Dec '10, 14:12

ryanmerket
112
accept rate: 0%

Hi, sorry about bringing this old post up, but have you received any responses regarding the problem? I am also having this problem, but the strange thing is that my other site (same server, same permissions) is ok. Thanks.

(12 Dec '12, 15:18) pelegrini

First: never, never, never use 777 permissions. On our servers, your PHP scripts execute as your own user account, so you never need to use 777 permissions.

If you're uploading large images, then you may need to raise your PHP upload limit. Instructions are here: Setting an Upload Limit.

Regarding your trouble deleting a post, I'm not sure what the problem could be there. If you're still having issues, then feel free to open a support ticket and we'll have a closer look at your issue.

permanent link

answered 31 Dec '10, 14:40

seanf
12.2k41836
accept rate: 37%

Changed to 700 for security reasons.

Image size is 12kb.

Opening support ticket.

(31 Dec '10, 14:41) ryanmerket
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×244

question asked: 31 Dec '10, 14:12

question was seen: 4,593 times

last updated: 12 Dec '12, 15:18

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM