WebFaction
Community site: login faq
0
1

I've set up my django app with the following relevant settings:

DEBUG = False
EMAIL_HOST = 'smtp.webfaction.com'
EMAIL_HOST_USER = 'abcitydb_dev'
EMAIL_HOST_PASSWORD = <my password>
DEFAULT_FROM_EMAIL = 'error@dev.abcitydb.gigamech.net'
SERVER_EMAIL = 'error@dev.abcitydb.gigamech.net'
EMAIL_PORT = 587

Everything works fine and I can send emails from the app using all the settings above, but I never get an email when a 500 error occurs (I'm testing this through a view that does nothing except raise an exception)

asked 23 Apr '13, 10:56

Gigamech
1525
accept rate: 0%


You need to specify a value for ADMINS in your settings. More information is available in the ADMINS section of the Django settings documentation.

Hope that helps!

permanent link

answered 23 Apr '13, 18:10

seanf
12.2k41836
accept rate: 37%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×909
×260
×69

question asked: 23 Apr '13, 10:56

question was seen: 3,671 times

last updated: 23 Apr '13, 18:10

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM