WebFaction
Community site: login faq

I've installed OwnCloud on a subdomain, but I'm having problems getting the OS X client to sync. There's a thread on the OwnCloud support forum which suggests the issue is caused by webdav.

Is it possible to disable webdav and if so how?

This is the OwnCloud thread: http://forum.owncloud.org/viewtopic.php?f=14&t=6507

Thanks

asked 06 Jun '13, 01:20

wicky
2326
accept rate: 0%

edited 06 Jun '13, 01:21

This is the full extent of OC's error logs...

Warning PHP mysql_close(): 47 is not a valid MySQL-Link resource at /home/myaccount/webapps/store/oc/lib/setup.php#277 June 6, 2013 10:12

Debug core
include path for class "OCA_FirstRunWizardConfig" starts with "apps/" June 6, 2013 10:17

Debug core
Adding user backend instance of OC_User_Database. June 6, 2013 10:17

(06 Jun '13, 12:22) wicky

Actually that was from the UI. This is the log file:

{"app":"PHP","message":"mysql_close(): 47 is not a valid MySQL-Link resource at \/home\/myaccount\/webapps\/store\/oc\/lib\/setup.php#277","level":2,"time":1370538734}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1370539005}
{"app":"core","message":"include path for class \"OCA_FirstRunWizard\\Config\" starts with \"apps\/\"","level":0,"time":1370539005}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1370539020}
{"app":"core","message":"include path for class \"OCA_FirstRunWizard\\Config\" starts with \"apps\/\"","level":0,"time":1370539020}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1370539028}
{"app":"core","message":"include path for class \"OCA_FirstRunWizard\\Config\" starts with \"apps\/\"","level":0,"time":1370539028}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1370539033}
{"app":"core","message":"include path for class \"OCA_FirstRunWizard\\Config\" starts with \"apps\/\"","level":0,"time":1370539033}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1370539035}
{"app":"core","message":"include path for class \"OCA_FirstRunWizard\\Config\" starts with \"apps\/\"","level":0,"time":1370539035}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1370539037}
{"app":"core","message":"include path for class \"OCA_FirstRunWizard\\Config\" starts with \"apps\/\"","level":0,"time":1370539037}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1370539039}
{"app":"core","message":"include path for class \"OCA_FirstRunWizard\\Config\" starts with \"apps\/\"","level":0,"time":1370539039}
{"app":"core","message":"Adding user backend instance of OC_User_Database.","level":0,"time":1370539115}
{"app":"core","message":"include path for class \"OCA_FirstRunWizard\\Config\" starts with \"apps\/\"","level":0,"time":1370539115}
(06 Jun '13, 12:25) wicky

WebDAV isn't enabled by default. It's only enabled when you create a WebDAV application via our control panel, and then only for that application.

The details you've reported don't appear to be related to WebDAV at all - rather, they appear to be related to some part of the database configuration of your application.

We have some generic database connection info in our docs here: Connecting to a Database

It also looks like your setup script might be trying to create a database user (I could be wrong, not familiar with OwnCloud). You don't have privileges to do that on our shared MySQL instance, so if there is no other way to set up your application, then you will need to use a private MySQL instance.

permanent link

answered 06 Jun '13, 11:14

seanf
12.2k41836
accept rate: 37%

edited 06 Jun '13, 12:53

Thanks Sean.

(06 Jun '13, 15:29) wicky
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×16
×7

question asked: 06 Jun '13, 01:20

question was seen: 6,917 times

last updated: 06 Jun '13, 15:39

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM