WebFaction
Community site: login faq

I have previously set up Public Key SSH access to a client's account on Webfaction. However, when I tried to do the same for my own account, I have been unable to make it work.

Tried from 2 different computers (one Ubuntu, one Windoze XP + Putty) following the instructions on http://docs.webfaction.com/user-guide/access.html?highlight=ssh#using-ssh-keys , however I always get a password prompt. In the debug log from my putty session, it says "server refused public key".

I've checked permissions both for my ~/.ssh folder (and authorized_keys file) on the Webfaction server and on my own Ubuntu box.

I assume there's something obvious I've overlooked???

Cheers, Rob Hills Waikiki, Western Australia

asked 09 Jan '11, 11:24

Rob Hills
2115
accept rate: 0%

It may be a bit difficult to diagnose this here. Could you open a support ticket so we can take a closer look?

(09 Jan '11, 11:48) David L ♦♦

Just to close this one off, one of the Webfaction Staff (thanks David) restarted the SSH daemon on the server hosting my account and that fixed my problem.

permanent link

answered 10 Jan '11, 09:23

Rob Hills
2115
accept rate: 0%

Beware setfacl -m d:u:username:anything # even setting to --- seems to confound ssh's safety checks.

To get this working again:

cd
getfacl . # and remember/store the settings for later reuse
setfacl -b .
setfacl -b .ssh
setfacl -b .ssh/authorized_keys
chmod 700 .ssh
chmod 600 .ssh/authorized_keys
setfacl -m u:nginx:r-x  # one thing I saw from the getfacl step
setfacl -m u:apache:r-x # another thing. Your needs may vary

There may be a better way to use setfacl to just remove the default: parts, which seem to have been the real issue. Maybe "setfacl -b -d ." would have worked?

permanent link

answered 26 Oct '11, 20:08

griswolf
2125
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×103
×2
×2

question asked: 09 Jan '11, 11:24

question was seen: 7,788 times

last updated: 26 Oct '11, 20:08

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM