WebFaction
Community site: login faq

I've been using the Pagespeed module (as introduced here) on a few of my apps since I started with WebFaction. However, when I visit my apps using the module, I no longer see the pagespeed header in HTTP response headers. Has Pagespeed been removed? If so, is there any way to get it back without compiling and running my own apache/nginx instances? I really loved the feature and it's a shame to not be able to utilize it any longer.

asked 05 Aug '13, 15:27

euantorano
1327
accept rate: 0%


Just for completeness, note that mod_pagespeed only works on html files and other static content, but does not work on dynamically processing code such as php.

permanent link

answered 29 Aug '13, 02:41

ryans ♦♦
5.0k93260
accept rate: 43%

It works fine on my end, on web412.

SERVER RESPONSE: 200 OK

Server: cloudflare-nginx

Date: Mon, 05 Aug 2013 21:00:09 GMT

Content-Type: text/html; charset="iso-8859-1"

Transfer-Encoding: chunked

Connection: keep-alive

Set-Cookie: __cfduid=d7c2b198658b2ee0a5aa9783483bb171e1375736408691;

expires="Mon, 23-Dec-2019 23:50:00 GMT"; path=/;

X-Mod-Pagespeed: 1.4.26.3-3101

Vary: Accept-Encoding

Cache-Control: max-age=0, no-cache

CF-RAY: 9966a4a5a5c0077

Content-Encoding: gzip

permanent link

answered 05 Aug '13, 16:02

ptiger99
12
accept rate: 0%

Strange. Here's my response header:

Cache-Control   no-cache, must-revalidate, max-age=0
Connection  keep-alive
Content-Encoding    gzip
Content-Type    text/html; charset=UTF-8
Date    Tue, 06 Aug 2013 06:43:21 GMT
Expires Wed, 11 Jan 1984 05:00:00 GMT
Link    <http://wp.me/2uiuX>; rel=shortlink
Pragma  no-cache
Server  nginx
Transfer-Encoding   chunked
Vary    Accept-Encoding, Accept-Encoding,Cookie
X-Pingback  http://www.euantor.com/xmlrpc.php

And here's my .htaccess snippet:

SetOutputFilter MOD_PAGESPEED_OUTPUT_FILTER

I'm on Web341.

(06 Aug '13, 01:45) euantorano

mod_pagespeed is enabled on web341 . It lives in "/usr/lib64/httpd/modules" and this line is enabled in the shared apache's httpd.conf:

LoadModule pagespeed_module /usr/lib64/httpd/modules/mod_pagespeed.so
(06 Aug '13, 03:27) ryans ♦♦

That's strange then. The X-MOD-PAGESPEED header is certainly not set. You can check for yourself here: euantor.com

(06 Aug '13, 12:30) euantorano

Send us a support ticket so we can look at your account/server directly.

(06 Aug '13, 17:19) johns

Sorry for the late response, but I'll submit a ticket now.

(17 Aug '13, 07:57) euantorano

I'm on Web340 and not seeing anything in my headers for a WP site either. Have tried both SetOutputFilter MOD_PAGESPEED_OUTPUT_FILTER and AddOutputFilterByType MOD_PAGESPEED_OUTPUT_FILTER text/html. Wondering too about what ryans has said below about it only working on static content, not PHP. Surely that's not the case? What would be the point of it then?

(12 Sep '13, 17:57) tyssen
showing 5 of 6 show 1 more comments

I am seeing the same issue on Web300. The library file for pagespeed in /usrlib64/httpd/modules is not executable. I wonder if that is not the reason for the issue. I am going to open a ticket for Web300.

permanent link

answered 16 Aug '13, 08:38

Leon Hedding
11
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×125
×15
×10
×5

question asked: 05 Aug '13, 15:27

question was seen: 3,229 times

last updated: 12 Sep '13, 17:57

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM