WebFaction
Community site: login faq

Does anyone else have this issue? This is my stderr from couchdb output:

heart_beat_kill_pid = 18174
heart_beat_timeout = 11
heart: Sat Nov  3 16:09:28 2012: Erlang has closed.^M
heart: Sat Nov  3 16:09:29 2012: Executed "/home/netpoetica/bin/couchdb -k". Terminating.^M

heart_beat_kill_pid = 25640
heart_beat_timeout = 11
heart: Sat Nov  3 16:15:44 2012: Erlang has closed.^M
heart: Sat Nov  3 16:15:45 2012: Executed "/home/netpoetica/bin/couchdb -k". Terminating.^M

heart_beat_kill_pid = 432
heart_beat_timeout = 11

heart_beat_kill_pid = 17754
heart_beat_timeout = 11
heart: Wed Jul 31 03:16:14 2013: Erlang has closed.^M
heart: Wed Jul 31 03:16:15 2013: Executed "/home/netpoetica/bin/couchdb -k". Terminating.^M

heart_beat_kill_pid = 14888
heart_beat_timeout = 11
heart: Fri Aug  2 23:04:53 2013: heart-beat time-out.^M
heart: Fri Aug  2 23:04:58 2013: Executed "/home/netpoetica/bin/couchdb -k". Terminating.^M

heart_beat_kill_pid = 2735
heart_beat_timeout = 11
heart: Sun Aug  4 12:17:22 2013: heart-beat time-out.^M
heart: Sun Aug  4 12:17:28 2013: Executed "/home/netpoetica/bin/couchdb -k". Terminating.^M

heart_beat_kill_pid = 20431
heart_beat_timeout = 11
heart: Thu Aug  8 20:33:14 2013: heart-beat time-out.^M
heart: Thu Aug  8 20:33:17 2013: Executed "/home/netpoetica/bin/couchdb -k". Terminating.^M

heart_beat_kill_pid = 3582
heart_beat_timeout = 11
heart: Fri Aug  9 03:45:19 2013: Erlang has closed.^M
heart: Fri Aug  9 03:45:20 2013: Executed "/home/netpoetica/bin/couchdb -k". Terminating.^M

heart_beat_kill_pid = 5869
heart_beat_timeout = 11

I have made an attempt to make it automatically restart by setting RESPAWN_TIMEOUT=5 in my bin/couchdb folder. It was installed via the instructions on webfaction boards. Aside from this, it runs fine, it just seems to intermittently kill_pid

Thanks in advance!

asked 09 Aug '13, 18:11

netpoetica
336
accept rate: 0%

You haven't exceeded your RAM quota, so your processes were not terminated by our system - so that's not the problem.

The "^M" characters in the output look suspicious. Those are Windows/DOS line-endings - have you perhaps fed any input, configuration files, etc to CouchDB while using Windows line endings? It's possible that this is crashing it.

(09 Aug '13, 20:39) ryans ♦♦

@ryans - I am working from a Mac OSX UNIX machine, using vim 100% percent of the time. My personal vim config shows all windows line endings, I can configure my vimrc on webfaction to do the same. I have a few ideas of where I could look but not 100% - any recommendations? So far I think these: local.ini, default.ini, bin/couchdb

(10 Aug '13, 07:51) netpoetica

The file in 'bin' is a binary, and would not have any line endings. The .ini files are likely. You can use the 'dos2unix' command on the server to convert the .ini files into UNIX format.

(10 Aug '13, 17:21) johns

thanks for your johns - I tried to use dos2unix and have manually scraped the files for typical chars, found nothing. It almost seems like it's something from erlang. The error I seem to get is from supervisor in what looks like a erlang function, or maybe from the bin/couchdb script

=SUPERVISOR REPORT==== 10-Aug-2013::22:51:11 ===
 Supervisor: {local,couch_secondary_services}
 Context:    start_error
 Reason:     {already_started,<0.98.0>}
 Offender:   [{pid,undefined},
              {name,db_update_notifier},
              {mfargs,{couch_db_update_notifier_sup,start_link,[]}},
              {restart_type,permanent},
              {shutdown,brutal_kill},
              {child_type,worker}]
[error] [<0.87.0>] {error_report,<0.30.0>,
                   {<0.87.0>,supervisor_report,
                    [{supervisor,{local,couch_server_sup}},
                     {errorContext,start_error},
                     {reason,shutdown},
                     {offender,
                         [{pid,undefined},
                          {name,couch_secondary_services},
                          {mfargs,{couch_secondary_sup,start_link,[]}},
                          {restart_type,permanent},
                          {shutdown,infinity},
                          {child_type,supervisor}]}]}}
 {"init terminating in do_boot",{{badmatch,{error,{bad_return,{{couch_app,start,[normal, 
 ["/home/netpoetica/etc/couchdb/default.ini","/home/netpoetica/etc/couchdb/local.ini"]]},{'EXIT',
 {{badmatch,{error,shutdown}},[{couch_server_sup,start_server,1,[{file,"couch_server_sup.erl"},
 {line,98}]},{application_master,start_it_old,4,[{file,"application_master.erl"},{line,274}]}]}}}}}},
 [{couch,start,0,[{file,"couch.erl"},{line,18}]},{init,start_it,1,[]},{init,start_em,1,[]}]}}
 Erlang has closed
 /home/netpoetica/lib/erlang/lib/os_mon-2.2.8/priv/bin/memsup: Erlang has closed.

 Crash dump was written to: erl_crash.dump
 init terminating in do_boot ()

I see a thing about "pid" undefined and I'm wondering if it's something to do with running processes or something, or maybe the text file that holds PIDs hasn't been cleared or can't be rewritten

(10 Aug '13, 17:53) netpoetica

If it is erlang, your best bet is to try and rebuild the stack from source, since it would be very difficult to debug. You might also think of posting on the CouchDB community, as they develop it and know more about its internal functions. If it is the pid file, simply removing it should fix it.

(10 Aug '13, 18:57) johns

@Johns notice how that error is saying CouchDB version 1.3, despite the fact that I have repeatedly installed 1.1.1? The instal script will not overwrite couch version 1.3 - I think this may be the problem. Going to try a couple of things to see if I can get make uninstall and distclean get rid of all couch stuff

(11 Aug '13, 07:56) netpoetica
showing 5 of 6 show 1 more comments

I noticed in the error log that it said "Couch version 1.3.1" even though I had used webfaction instructions and run install for 1.1.1 - it looks like 1.3.1 would not go away.

Anyhow, I tried to run make uninstall and make distclean to get rid of Couch, but I only had the source of couchdb 1.1.1. So I ran those from version 1.1.1 source folder (depsite having version 1.3.1 installed), tried to install couch 1.1.1 again, and STILL saw an error about having couch 1.3.1. So I downloaded the source of couch 1.3.1 and ran the last three pieces of your install script - boom, couch works and its version 1.3.1

For anyone else running into couch troubleshooting problems, here are some of the most helpful resources I found:

http://wiki.apache.org/couchdb/Troubleshooting - Checking Dependencies in Erlang http://www.erlang.org/doc/apps/erts/crash_dump.html - Interpreting Erlang Crash Dumps

And of course, http://community.webfaction.com/questions/557/installing-couchdb - the webfaction docs. I ultimately ended up making a couple of small bash scripts from this script to try and isolate any install errors.

permanent link

answered 11 Aug '13, 08:19

netpoetica
336
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×13

question asked: 09 Aug '13, 18:11

question was seen: 3,131 times

last updated: 11 Aug '13, 08:19

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM