WebFaction
Community site: login faq

Via the Control panel I have created a database and a user to access the mysql database. but today i get the error: in my webpage Database unavailable

Access denied for user 'anababa'@'localhost' (using password: YES)

But this user in fact can connect to the database via phpmyadmin?

i am trying to use my text pattern site. ( i believe that I in fact managed to install TxP last week and had to connect to the DB for this to take place, but now i get these errors)

asked 03 Dec '13, 17:20

baba
47724
accept rate: 0%


I've had a similar problem.

This is also occuring on the trouble ticket system, which is..... disturbing.

edit: Oh sorry this is a stack overflow themed site. I'm not sure another way to add additional information. Unfortunately as the trouble ticket system is down I don't see another option.

permanent link

answered 03 Dec '13, 19:03

shayneo
11
accept rate: 0%

edited 03 Dec '13, 19:05

you say yo have had the problem. what was the solution.

(03 Dec '13, 22:13) baba

This is also occuring on the trouble ticket system, which is..... disturbing.

You're seeing an "Access denied for user '<soandso>'@'localhost' (using password: YES)" error at https://help.webfaction.com/ ?

If so, that's very strange, and we're not seeing similar reports currently. Please send an email to support@webfaction.com from any registered email address on your account and we'll be happy to help.

(03 Dec '13, 22:39) ryans ♦♦

Access denied for user 'anababa'@'localhost' (using password: YES) But this user in fact can connect to the database via phpmyadmin?

There are a couple of possible reasons for this:

  • The database user doesn't exist when connecting from "localhost" but exists for some other source.
  • The password that your application is using is wrong, but you're using the correct password at phpmyadmin

Firstly and just to confirm - you're using the server's Shared MySQL instance (and not a private MySQL instance) - right? If you're still seeing this and can be sure that the password is correct, please open a support ticket and provide the following:

  • Where the database connection details are configured in your application
  • The phpmyadmin URL you're using
  • The username and password you're using in phpmyadmin

Once we can reproduce the issue, we should be able to investigate further. Hope that helps!

permanent link

answered 03 Dec '13, 22:45

ryans ♦♦
5.0k93460
accept rate: 43%

At the moment without having made any changes to any settings the website is functioning. This is both good and not so good.

Good that we have connectivity, but it's worrisome that for some random reason the user was not being allowed access for some particular reason.

(04 Dec '13, 01:14) baba
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×108
×84
×14

question asked: 03 Dec '13, 17:20

question was seen: 1,945 times

last updated: 04 Dec '13, 02:22

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM