WebFaction
Community site: login faq

When I tried to deploy my project from bitbucket to webfaction, but I get this error:

sh: hg: command not found

but at server hg works fine.

Also i tried to add this to .hgrc on server:

remotecmd = ~/bin/hg

but it isn't work

asked 12 Dec '13, 16:23

quantizer
11
accept rate: 0%


You probably need to set your PATH environment variable in your deploy.rb, so that it include your /home/YOU/bin directory (or wherever your hg executable lives).

permanent link

answered 12 Dec '13, 17:55

seanf
12.2k31836
accept rate: 37%

I tried to do PATH=$PATH:~/bin/hg; export PATH before task deploy:update_code but this is not fix the problem.

(13 Dec '13, 08:34) quantizer
-1

You should send us a support ticket since you will have to provide the ability for us to test it in real-time, the user community is not a good forum for this kind of troubleshooting.

permanent link

answered 12 Dec '13, 17:23

johns ♦♦
5.3k212
accept rate: 23%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×20
×14
×6

question asked: 12 Dec '13, 16:23

question was seen: 1,588 times

last updated: 13 Dec '13, 08:34

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM