WebFaction
Community site: login faq

I'm very new to webfaction, and for the most part am very excited at what I've found. But I seem to have hit the wall with using phpmyadmin with the private mysql instance. The reference for installing phpmyadmin mentions:

SSH into your server and run the following commands to download and extract PMA:

cd ~ wget http://downloads.sourceforge.net/project/phpmyadmin/phpMyAdmin/3.5.2.2/phpMyAdmin-3.5.2.2-english.tar.bz2?r=http%3A%2F%2Fwww.phpmyadmin.net%2Fhome_page%2Fdownloads.php&ts=1348609141&use_mirror=freefr"

When I do that, the terminal windows shows the > and just sits there.

What needs to happen?

Thanks!

asked 15 Jan '14, 01:08

phpLinda
1014
accept rate: 0%


  1. Create a new "Static/PHP/CGI" type app, its name will alter the following commands,
  2. Run this command to download the tarball
    cd ~
    wget http://superb-dca2.dl.sourceforge.net/project/phpmyadmin/phpMyAdmin/4.1.4/phpMyAdmin-4.1.4-english.tar.bz2
  3. Run this command to extract it:
    tar -xf phpMyAdmin-4.1.4-english.tar.bz2
  4. Run this command to copy the extracted files into the application directory:
    cp -r phpMyAdmin-4.1.4-english/* ~/webapps/name_of_application/
  5. Mount the application from step 1 to a domain as you would other apps.
  6. Configure phpmyadmin to use the custom server and anything else you desire, use their documentation for details and options.
permanent link

answered 15 Jan '14, 05:24

johns
5.4k312
accept rate: 23%

edited 15 Jan '14, 18:16

seanf
12.2k41836

Thanks for your prompt response.

Running the wget I get a 404 Not found. But accessing the url directly does get me to a download. So something's missing, but I'm not sure what. Here's the result of the wget:

[multilks@web439 ~]$ wget http://downloads.sourceforge.net/project/phpmyadmin/phpMyAdmin/3.5.2.2/phpMyAdmin-3.5.2.2-english.tar.bz --2014-01-15 16:11:12-- http://downloads.sourceforge.net/project/phpmyadmin/phpMyAdmin/3.5.2.2/phpMyAdmin-3.5.2.2-english.tar.bz Resolving downloads.sourceforge.net... 216.34.181.59 Connecting to downloads.sourceforge.net|216.34.181.59|:80... connected. HTTP request sent, awaiting response... 404 Not Found 2014-01-15 16:11:12 ERROR 404: Not Found.

(15 Jan '14, 16:18) phpLinda

I've updated the instructions with a working URL.

(15 Jan '14, 18:16) seanf

Thanks...that worked!

Now to the config :)

(16 Jan '14, 06:43) phpLinda
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×23
×12

question asked: 15 Jan '14, 01:08

question was seen: 2,676 times

last updated: 16 Jan '14, 06:43

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM