WebFaction
Community site: login faq

Hi, I created a new node application from control panel, the application says 0.10.24, but when I tried to install DocPad with :

npm install -g npm; npm install -g docpad@6.63

it give me this error:

Error: npm doesn't work with node v0.6.19 Required: node@>=0.8

my node -v output is v0.6.19 and npm -v 1.4.2

when I try npm update -g i get this error:

Error: npm doesn't work with node v0.6.19 Required: node@>=0.8

How can I update node and npm?

thanks,

federico

asked 14 Feb '14, 20:58

fede2001
133
accept rate: 0%


You need to run the version of node that is installed with the app, in the bin directory in the application root. If you don't explicitly call that path the commandline session will likely pick up the system version, which is older.

permanent link

answered 15 Feb '14, 03:26

waynek
4254
accept rate: 27%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×67

question asked: 14 Feb '14, 20:58

question was seen: 2,045 times

last updated: 15 Feb '14, 03:26

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM