WebFaction
Community site: login faq

I'm getting the following error message:

414 Request-URI Too Large, nginx

How can I increase the allowed maximum size of the url parameters?

What is the default?

Thanks!

asked 07 May '14, 10:17

tpip
4121421
accept rate: 0%

Can you give an example of a URL that you're using that returns the 414 error?

(07 May '14, 19:16) seanf

Just a plain url like: www.mysite.com/i=something_fairly_long

I need to be able to send the parameter as a GET, not a POST because it is part of an iframe src: <iframe src="the_url">

(08 May '14, 04:11) tpip

We're currently using the default value of 8k for large_client_header_buffers in Nginx. You can't increase these parameters yourself.

Please open a support ticket to let us know the size of the request that you need to be able to accept, and we'll look into the possibility of increasing the setting.

permanent link

answered 08 May '14, 20:50

seanf
12.2k42136
accept rate: 37%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×186

question asked: 07 May '14, 10:17

question was seen: 10,062 times

last updated: 08 May '14, 20:50

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM