WebFaction
Community site: login faq

Hello everybody!

I was achieving a 400 error for a while and so i took the entire django app website down and uploaded back up again. However this time I am recieving a 500 error now. This was the most current error log.

[Wed May 21 13:46:50 2014] [notice] caught SIGTERM, shutting down
[Wed May 21 21:21:58 2014] [notice] Apache/2.2.25 (Unix) mod_wsgi/3.4 Python/2.7.5 configured -- resuming normal operations
[Wed May 21 22:08:28 2014] [error] [client 127.0.0.1] Target WSGI script not found or unable to stat: /home/clearlylit/webapps/bdng_landing/myproject
[Wed May 21 22:10:57 2014] [notice] caught SIGTERM, shutting down
[Wed May 21 22:11:02 2014] [notice] Apache/2.2.25 (Unix) mod_wsgi/3.4 Python/2.7.5 configured -- resuming normal operations
[Wed May 21 22:47:37 2014] [notice] caught SIGTERM, shutting down
[Wed May 21 22:47:42 2014] [notice] Apache/2.2.25 (Unix) mod_wsgi/3.4 Python/2.7.5 configured -- resuming normal operations
[Wed May 21 22:50:48 2014] [notice] caught SIGTERM, shutting down
[Wed May 21 22:50:53 2014] [notice] Apache/2.2.25 (Unix) mod_wsgi/3.4 Python/2.7.5 configured -- resuming normal operations

Thanks for reading!

Tommy

asked 21 May '14, 23:43

clearlylit
1314
accept rate: 0%

edited 21 May '14, 23:47

seanf
12.2k42136


502 means that the front-end web server can't contact your back-end server, usually either because:

a. The back-end server isn't running, or..

b. The back-end server is running, but is listening on the wrong port.

I just checked your account and confirmed that it is the second problem in this case. To fix it:

  1. Go to https://my.webfaction.com/applications, click your Django app, and make a note of the port number assigned to your app.
  2. On the server, edit your app's httpd.conf to set the correct port number (on the "Listen" directive).
  3. Restart your Apache.

Hope that helps!

permanent link

answered 21 May '14, 23:50

seanf
12.2k42136
accept rate: 37%

Awesome, Thanks Sean!

However now I have this interesting 400 error. I am hoping that in 20 min the server reconfigures. Otherwise is it still a problem with my httpd.conf?

Regards,

Tommy

(22 May '14, 13:32) clearlylit
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×108
×21

question asked: 21 May '14, 23:43

question was seen: 3,952 times

last updated: 22 May '14, 13:36

                              
WEBFACTION
REACH US
SUPPORT
LEGAL
© COPYRIGHT 2003-2021 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM