WebFaction
Community site: login faq

I am developing an application where the user may have long stretches of no communication with the server. On my old server I had no issues with timeouts (where the client disconnects with the server when no action occurs). Since I have moved to web faction, it seems that if there is longer than roughly 5 minutes without any communication, then the client and the server get disconnected.

Is there a setting I can change to fix this, or do I have to do it with my program?

Thanks

asked 10 Nov '14, 20:53

jnr
112
accept rate: 0%


All requests time out after 5 minutes if they are using the front-end nginx server,

proxy_read_timeout 300;

If this an app which listens on a port than you can open that port within the control panel and access it directly, thus bypassing the proxy.

permanent link

answered 10 Nov '14, 22:18

johns
5.4k312
accept rate: 23%

Thanks for the reply.

I set up the application as one of these:

"Custom websockets app (listening on port)"

I don't see how to open a port in the control panel though.

(10 Nov '14, 22:23) jnr

If you are initially setting up the application, it is step 10: http://docs.webfaction.com/user-guide/websites.html#create-an-application-with-the-control-panel

You can go into the control panel, select Domains/Websites, then select applications, choose the application, and near the bottom of the application page will be a checkbox with 'open port' next to it. Select the checkbox, then save.

permanent link

answered 10 Nov '14, 22:43

todl
353
accept rate: 12%

edited 10 Nov '14, 22:43

Excellent, thank you!

(10 Nov '14, 22:47) jnr

OK, So I just tried this, and when I click to save it says:

"This type of application does not run on an open port."

My app type is "Custom Websockets App (listening on a port)"

(21 Nov '14, 02:07) jnr

This might be confusing, but actually a "Custom Websockets App (listening on a port)" doesn't run on an open port.

It does listen on a port; that's how the front-end Nginx proxy_passes websockets connections to it, but that's not an open port in the firewall.

In order to use an open port, thus bypassing Nginx completely, you would use a "Custom Application (listening on port)", and then mark the "Open Port" option.

A "Custom Application" is a more generic and basic application type. It doesn't know about Websockets data and it can be directly opened in the firewall.

(21 Nov '14, 04:52) ryans ♦♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×27

question asked: 10 Nov '14, 20:53

question was seen: 2,391 times

last updated: 21 Nov '14, 04:52

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM