WebFaction
Community site: login faq

Hi, I'm trying to install the Python 'pyephem' package. easy_install works but when I import the module I get this error:

ImportError: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /home2/zerogravitas/lib/python2.5/pyephem-3.7.3.4-py2.5-linux-i686.egg/ephem/_libastro.so)

Is there any way around this?

Thanks.

asked 26 Oct '10, 15:56

zerog
4124
accept rate: 100%


Obvious answer - download the source and a simple python setup.py install :)

permanent link

answered 26 Oct '10, 17:16

zerog
4124
accept rate: 100%

By using the more modern pip command instead of the ancient easy_install command, the package will be compiled for you from source code instead of using the binary on PyPI. Ian Bicking declined to support binary packages with pip because he got tired of exactly this problem.

$ easy_install pip    # if you find pip is not already installed
$ pip install pyephem

See if that works and let us know!

permanent link

answered 28 Oct '10, 17:11

Brandon Crai...
162
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×337
×6
×1

question asked: 26 Oct '10, 15:56

question was seen: 4,596 times

last updated: 28 Oct '10, 17:11

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM