WebFaction
Community site: login faq

Hi there,

I have created a static/cgi/php app running DokuWiki, attached it to a website running HTTPS protocol. The problem is after login, it is redirected to the following URL:

https://sub.domain.com:80/doku.php?id=start

The port 80 in the URL is causing an error. If I remove the ":80" from the URL, it then works fine.

Is there a way to configure DokuWiki not to append port 80 to the URL after a secure login?

Please kindly advise.

Thanks, David Fung

asked 26 Nov '14, 00:46

davidfung
1112
accept rate: 0%


I think you can set this in "config:baseurl" from the DokuWiki Config.

permanent link

answered 26 Nov '14, 07:15

ryans ♦♦
5.0k93260
accept rate: 43%

Hi Ryans,

Thanks! It works after setting the following in conf/dokuwiki.php per your suggestion, although I still don't know why a port 80 was added to the URL before :P

$conf['baseurl'] = 'https://sub.domain.com';

David

(27 Nov '14, 03:18) davidfung
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×74
×3

question asked: 26 Nov '14, 00:46

question was seen: 3,037 times

last updated: 27 Nov '14, 03:51

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM