WebFaction
Community site: login faq

Hi,

I have a django site running on web394 but it's being very slow. I've made sure it's configured as per other information on here regarding slow start times (wsgi pre-loading..) and that seems good.

One thing I have noticed is that the IO wait time seems very high. Comparing top output to the times when the site takes forever to load shows it is always when the wait times are high. Here's some examples from top.

Cpu(s): 48.7%us,  8.8%sy,  0.0%ni, 11.1%id, 31.1%wa,  0.0%hi,  0.3%si,  0.0%st
Cpu(s): 39.8%us,  8.7%sy,  0.0%ni, 12.9%id, 38.0%wa,  0.0%hi,  0.5%si,  0.0%st
Cpu(s): 6.2%us,  3.1%sy,  0.0%ni,  7.4%id,  83.0%wa,  0.0%hi,  0.2%si,  0.0%st

When the wa is low (< 5%) the site loads perfectly fast. Anything above 10% and you do notice the extra time it takes pages to load so this leads me to believe it's the server rather than a site performance issue.

So, my questions are - is web394 overloaded or having any hardware issues? (It's rare for wa to dip below 5%, and very, very rare for it to drop below 2%.) What are the wait times on other servers? What can be done to fix this and is it likely to keep happening?

asked 01 Apr '15, 09:54

rogert
114
accept rate: 0%


is web394 overloaded or having any hardware issues?

I've checked the load history on Web394 for the past week, and while there are occasional periods of elevated load (lasting no more than a few minutes), overall the machine seems to be performing acceptably.

What are the wait times on other servers?

The majority of our other servers are comparable to web394, or better.

What can be done to fix this and is it likely to keep happening?

If you're not doing so already, you could optimize your site to make it less affected by disk IO wait time, for example you could use memcached to cache expensive database queries.

If you'd like us to look into your specific issues, feel free to open an urgent support ticket the next time you notice your site performing slowly, and we'll look into it right away.

permanent link

answered 01 Apr '15, 17:44

seanf
12.2k41836
accept rate: 37%

Thanks. It was already using memcached. It seems to be magically faster since posting this yesterday. I'll keep an eye on it and raise a ticket or post another moan here if it gets unacceptable again.

(02 Apr '15, 09:23) rogert
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×909
×97
×26

question asked: 01 Apr '15, 09:54

question was seen: 1,500 times

last updated: 02 Apr '15, 09:23

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM