WebFaction
Community site: login faq

Using Transmit on iOS and connecting to the server via sftp works fine but when editing a file it brings up the error:

Could not change attributes of "index.html". Make sure you have permissions to modify this file. The server or file may not allow you to adjust permissions. Double-check that the permissions in the Rules preferences are set correctly.

When checking via desktop the file has changed.

Am I missing something? Is there anything one can do?

asked 24 Aug '15, 14:00

tomson
3116
accept rate: 0%

edited 24 Aug '15, 18:23

Can you please update your question to include the exact error message that you're seeing?

(24 Aug '15, 17:40) seanf

Thanks @seanf

(24 Aug '15, 18:24) tomson

Support for Panic's Transmit suggest:

this error is the result of a Transmit feature, Safe Save, that writes a temporary file to the remote server, then renames it once it’s done transferring. It also attempts to set the modification date to match the original file, which doesn’t seem to be supported by your server. Confusingly, the error message just says “Could not change attributes” — the modification date is the attribute it’s referring to, rather than user permissions on the file.

The good news is your files are being uploaded and saved. The bad news is this error message will pop up each time you upload a file to this server. Disabling the Safe Save feature isn’t currently possible, I’m afraid, but we’re looking into making it an option in an upcoming update to Transmit.

Transmit uses the setstat command to modify the last time the file was written to, which is a pretty standard command on most servers. I suspect the command is available on this server, but your user account doesn't have permission to run it. You may want to get in touch with the folks there to see why your account isn’t able or doesn't have permission to run setstat against your files. If they can grant this, the error should go away automatically.

permanent link

answered 24 Aug '15, 18:50

tomson
3116
accept rate: 0%

edited 24 Aug '15, 18:50

That sounds like the likely explanation.

Unfortunately, setstat is not installed, and we have no plans to install it. If you can find the source for it, then you can probably build and install it in your home directory.

(24 Aug '15, 19:17) seanf

seanf,

We have the same issue. Our users are uploading files to Red Hat. Can you send me a link to where I can download setstat source?

Thanks

Jessie

permanent link

answered 03 Sep '15, 13:45

jaquino
111
accept rate: 0%

I haven't been able to find a link for it, sorry.

(03 Sep '15, 16:04) seanf
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×31
×2
×1

question asked: 24 Aug '15, 14:00

question was seen: 2,899 times

last updated: 03 Sep '15, 16:04

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM