WebFaction
Community site: login faq

Hello,

I've been struggling with Django for some time now. I have followed the instructions here: https://docs.webfaction.com/software/django/getting-started.html

What's missing from these instructions is how to install requirements. I have followed the usual procedure:

  1. Install pip
  2. pip install -r requirements.txt

... and I end up with this error:

    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 20, in <module>
      File "/tmp/pip-build-eqv3vM/pandas/setup.py", line 631, in <module>
        **setuptools_kwargs)
      File "/usr/local/lib/python2.7/distutils/core.py", line 111, in setup
        _setup_distribution = dist = klass(attrs)
      File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py", line 239, in __init__
        self.fetch_build_eggs(attrs.pop('setup_requires'))
      File "/usr/local/lib/python2.7/site-packages/setuptools/dist.py", line 263, in fetch_build_eggs
        parse_requirements(requires), installer=self.fetch_build_egg
      File "/usr/local/lib/python2.7/site-packages/pkg_resources.py", line 576, in resolve
        raise VersionConflict(dist,req) # XXX put more info here
    pkg_resources.VersionConflict: (numpy 1.5.0 (/usr/local/lib/python2.7/site-packages), Requirement.parse('numpy>=1.7.0'))

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-eqv3vM/pandas

I have no idea what to do here. How do I install packages? I followed these instructions and it doesn't help: https://docs.webfaction.com/software/python.html?highlight=easy_install#installing-python-packages

How do I install packages to myapp folder? Do I have to install one by one following this:

To use easy_install to install a package to a specific web application which makes use of the Python interpreter, enter PYTHONPATH=$HOME/webapps/app_name/lib/pythonX.Y easy_install-X.Y --install-dir=$HOME/webapps/app_name/lib/pythonX.Y --script-dir=$HOME/webapps/app_name/bin module_name, where app_name is the name of the web application as it appears in the control panel and press Enter.

Thanks for your help. Let me know if you need additional info.

asked 01 Sep '15, 16:59

Borut
112
accept rate: 0%

edited 01 Sep '15, 17:03


Okay, I will answer my own question.

I used solution from this post: https://community.webfaction.com/questions/13404/importing-matplotlib-121

pip install -I -U --user numpy==1.9.2

I can now install dependencies.

permanent link

answered 01 Sep '15, 17:24

Borut
112
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×909
×337
×1

question asked: 01 Sep '15, 16:59

question was seen: 2,637 times

last updated: 01 Sep '15, 17:24

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM