WebFaction
Community site: login faq

Hi, I'm did an install of pip2.7 install django-markdown --no-use-wheel -U --install-option="--install-scripts=$PWD/bin" --install-option="--install-lib=$PWD/lib/python2.7" and got the error

    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1] Traceback (most recent call last):
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1]   File "/home/kbuzz/lib/python2.7/django/core/handlers/wsgi.py", line 170, in __call__
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1]     self.load_middleware()
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1]   File "/home/kbuzz/lib/python2.7/django/core/handlers/base.py", line 52, in load_middleware
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1]     mw_instance = mw_class()
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1]   File "/home/kbuzz/lib/python2.7/django/contrib/redirects/middleware.py", line 18, in __init__
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1]     if not apps.is_installed('django.contrib.sites'):
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1]   File "/home/kbuzz/lib/python2.7/django/apps/registry.py", line 231, in is_installed
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1]     self.check_apps_ready()
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1]   File "/home/kbuzz/lib/python2.7/django/apps/registry.py", line 124, in check_apps_ready
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1]     raise AppRegistryNotReady("Apps aren't loaded yet.")
    [Mon Nov 09 12:38:36 2015] [error] [client 127.0.0.1] AppRegistryNotReady: Apps aren't loaded yet.

So I tried to reinstall the apps again (previously experienced the same error when I tried to upgrade to the django 1.8) with pip2.7 install -r req.txt --no-use-wheel -U --install-option="--install-scripts=$PWD/bin" --install-option="--install-lib=$PWD/lib/python2.7" --user and still getting the same error. The Django app is on /webapps/django The site www.kenyabuzz.com is now down and I'm unable to bring it back up.

asked 09 Nov '15, 10:36

six_wars
11311
accept rate: 100%

edited 09 Nov '15, 11:09

Can you try getting the latest wsgi.py file that is compatible with the version of Django you are using, replace it, then restart Apache, and try again?

(09 Nov '15, 23:04) NickR ♦♦
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×909
×337

question asked: 09 Nov '15, 10:36

question was seen: 2,802 times

last updated: 09 Nov '15, 23:04

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM