WebFaction
Community site: login faq

This is a weird bug, but I can't get my cronjob to work. Here's the system date:

[me@web485 MyApp]$ date Sat Apr 30 16:34:22 UTC 2016

My cron:

[me@web485 MyApp]$ crontab -l 35 16 * * * echo hello

I cannot get it to run the command no matter what I do. I've tried all sorts of different commands on that line in the crontab, including ones that aren't output dependent (like one that posts to my server), but I don't ever get anything back. Am I somehow misusing the cronjob?

asked 30 Apr '16, 16:37

packd
157
accept rate: 0%


What's shown in your question isn't working because cron jobs don't write to the terminal. Try directing the output to a file. One way would be like:

35 16 * * * echo hello >> $HOME/output.txt

The documentation on cron describes how to log the output of your cron jobs.

permanent link

answered 30 Apr '16, 16:57

maryh
1.3k7
accept rate: 35%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×909
×81
×14

question asked: 30 Apr '16, 16:37

question was seen: 1,120 times

last updated: 30 Apr '16, 16:57

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM