WebFaction
Community site: login faq

The script creates an archive locally and then extracts it onto webfaction. This has been working flawlessly for the last 2 years. This last month however I've encountered a strange issue.

The files are not being overwritten. When this happens, I have to SSH into the server and manually remove the file, before running the Ansible deploy script again.

Does anyone know why this might not be overwriting files as it used to?

Note that I'm using the ansible unarchive module in my playbook.

asked 23 Nov '16, 11:44

andre
1129
accept rate: 0%

edited 25 Nov '16, 10:26

Can you add logging to your script to see if there is any error when replacing that file?

(23 Nov '16, 15:06) bmeyer71 ♦♦
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×337
×3

question asked: 23 Nov '16, 11:44

question was seen: 1,746 times

last updated: 25 Nov '16, 10:26

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2016 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM