WebFaction
Community site: login faq

I am attempting to set up SSL certificates on my domain using letsencrypt_webfaction. I had this all working, then I went on vacation and my server was migrated. Now everything is bananas and I can’t sort it out. Anyway, my attempted set-up:

I have one application for serving content: mbserver I have two domains: foo.webfactional.com and secure.foo.webfactional.com

In my Websites pane, I have two set up: - mbsite (HTTP) serves mbserver app for: http://foo.webfactional.com and http://secure.foo.webfactional.com - mbsite_secure (HTTPS) serves mbserver app for: https://foo.webfactional.com and https://secure.foo.webfactional.com

(yes, I know that http://secure... isn’t actually at all secure.)

I can curl http://foo.webfactional.com, but http://secure.foo.webfactional.com fails (It gives me WebFaction’s default “Coming soon” page). I think for the scope of this question, it’s likely the existence of mbsite_secure can be ignored, but I’m including it for completeness.

This honestly seems like the easiest part of the whole process, so I’m a bit beside myself. Please help! Any thoughts about what I might be doing wrong?

asked 25 Jun, 22:04

nitefloat's gravatar image

nitefloat
312
accept rate: 0%


It can take a few minutes for control panel changes to be deployed on the web server, so if you were checking things immediately after you made changes in the panel, then that would be the likely explanation.

If you're still seeing this issue at this time, then please open a support ticket and we'll be happy to look into it further.

permanent link

answered 26 Jun, 16:28

seanf's gravatar image

seanf ♦♦
11.6k21333
accept rate: 37%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×125
×72
×57

question asked: 25 Jun, 22:04

question was seen: 109 times

last updated: 26 Jun, 16:28

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2016 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM