WebFaction
Community site: login faq

I have a ticket in, but I thought I'd spread the love since I have sites down.

I have three identical Django apps running. Two of the three have gone down. There haven't been any code changes in weeks. This is the error:

[Tue May 15 19:11:58.938089 2018] [wsgi:error] [pid 21143:tid 140173906110336] mod_wsgi (pid=21143): Target WSGI script '/home/myaccount/webapps/myproject/recenroll/recenroll/wsgi.py' cannot be loaded as Python module.
[Tue May 15 19:11:58.938163 2018] [wsgi:error] [pid 21143:tid 140173906110336] mod_wsgi (pid=21143): Exception occurred processing WSGI script '/home/myaccount/webapps/myproject/recenroll/recenroll/wsgi.py'.
[Tue May 15 19:11:58.938193 2018] [wsgi:error] [pid 21143:tid 140173906110336] Traceback (most recent call last):
[Tue May 15 19:11:58.938218 2018] [wsgi:error] [pid 21143:tid 140173906110336]   File "/home/myaccount/webapps/myproject/recenroll/recenroll/wsgi.py", line 36, in <module>
[Tue May 15 19:11:58.938290 2018] [wsgi:error] [pid 21143:tid 140173906110336]     from django.core.wsgi import get_wsgi_application
[Tue May 15 19:11:58.938306 2018] [wsgi:error] [pid 21143:tid 140173906110336]   File "/home/myaccount/lib/python2.7/django/core/wsgi.py", line 2, in <module>
[Tue May 15 19:11:58.938733 2018] [wsgi:error] [pid 21143:tid 140173906110336]     from django.core.handlers.wsgi import WSGIHandler
[Tue May 15 19:11:58.938751 2018] [wsgi:error] [pid 21143:tid 140173906110336]   File "/home/myaccount/lib/python2.7/django/core/handlers/wsgi.py", line 3, in <module>
[Tue May 15 19:11:58.940081 2018] [wsgi:error] [pid 21143:tid 140173906110336]     import cgi
[Tue May 15 19:11:58.940104 2018] [wsgi:error] [pid 21143:tid 140173906110336]   File "/usr/lib64/python2.7/cgi.py", line 50, in <module>
[Tue May 15 19:11:58.941269 2018] [wsgi:error] [pid 21143:tid 140173906110336]     import mimetools
[Tue May 15 19:11:58.941289 2018] [wsgi:error] [pid 21143:tid 140173906110336]   File "/usr/lib64/python2.7/mimetools.py", line 6, in <module>
[Tue May 15 19:11:58.941639 2018] [wsgi:error] [pid 21143:tid 140173906110336]     import tempfile
[Tue May 15 19:11:58.941657 2018] [wsgi:error] [pid 21143:tid 140173906110336]   File "/usr/lib64/python2.7/tempfile.py", line 35, in <module>
[Tue May 15 19:11:58.942287 2018] [wsgi:error] [pid 21143:tid 140173906110336]     from random import Random as _Random
[Tue May 15 19:11:58.942308 2018] [wsgi:error] [pid 21143:tid 140173906110336]   File "/usr/lib64/python2.7/random.py", line 49, in <module>
[Tue May 15 19:11:58.943169 2018] [wsgi:error] [pid 21143:tid 140173906110336]     import hashlib as _hashlib
[Tue May 15 19:11:58.943198 2018] [wsgi:error] [pid 21143:tid 140173906110336]   File "/usr/lib64/python2.7/hashlib.py", line 116, in <module>
[Tue May 15 19:11:58.943607 2018] [wsgi:error] [pid 21143:tid 140173906110336]     import _hashlib
[Tue May 15 19:11:58.943640 2018] [wsgi:error] [pid 21143:tid 140173906110336] ImportError: /lib64/libresolv.so.2: symbol __h_errno, version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

Again, no changes and one of the sites is still up. I can log in via the shell and access the app with manage.py shell without a problem.

asked 15 May, 21:47

leehinde
45111
accept rate: 0%


Team WebFaction has posted about the issue. Solution is to restart the Apache stack:

The Apache stack needs to fully stop for this to be fixed. You can do that by starting an ssh session, traversing to the directory hosting your app, and using the stop and start scripts:

cd ~/webapps/your_app
./apache2/bin/stop
./apache2/bin/start
permanent link

answered 16 May, 08:45

Pratyush
111
accept rate: 0%

Turns out it's a know issue on the WF side.

permanent link

answered 15 May, 22:18

leehinde
45111
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×900
×54

question asked: 15 May, 21:47

question was seen: 492 times

last updated: 16 May, 08:45

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2016 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM