WebFaction
Community site: login faq

I have my hosting with Webfaction, and got a free Lets Encrypt Certificate, I had SSL on Cloudflare set to Full (Strict)

And then got the message below. To fix this I set SSL in CLoudflare to off now I get the webfaction issue where it say's it is not configured correctly. I havent changed anything on my Hosting though.

This is probably caused by a redirect or web app that catches URLs under /.well-known/acme-challenge/, or a Cloudflare set-up that doesn't exclude them. We've set up the following URLs you can try to visit if you want to fix the problem yourself:

http://www.basingstokefishandchips.co.uk/.well-known/acme-challenge/available http://basingstokefishandchips.co.uk/.well-known/acme-challenge/available

The HTTP status should be 200, and you will be able to see the file's contents that we are serving. This should work not just for the file "available", but any URL that starts with /.well-known/acme-challenge/.

asked 15 Aug, 21:09

Kurt0375
112
accept rate: 0%


As far as I can see you do not have a website record in your account to serve the sites over HTTP, only HTTPS. That would explain the not configured message.

"If you need your site to be available over both HTTP and HTTPS, then create two website records, one HTTP and the other HTTPS, and ensure that both sites are assigned to the same IP address."

Ref: https://docs.webfaction.com/user-guide/websites.html#secure-sites-https

permanent link

answered 15 Aug, 21:48

NickR ♦♦
4415
accept rate: 19%

Hi, I tried this seems to work but http loads teh website correctly but https doesnt load it correctly. https://basingstokefishandchips.co.uk http://basingstokefishandchips.co.uk

What i did was create a new website in the control panel linked the 2 urls as per the ssl but disabled SSL and re-used the existing app?

(03 Sep, 11:45) Kurt0375

I've tried loading your site using firefox and a lot of the CSS files were blocked by my browser because they were still being served from http.

You can use Ctrl + U to view your source code as it is rendered by your browser.

You will need to locate those files and make sure that they use https:// as the protocol when the page is loading over https.

(03 Sep, 11:54) iliasr ♦♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×29
×7
×1

question asked: 15 Aug, 21:09

question was seen: 283 times

last updated: 03 Sep, 11:54

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM