WebFaction
Community site: login faq

The current WebFaction Rails installs Rails 3.0.5. The current version of Redmine appears to want v2.3.4. When I try to run any command (like "rake db:migrate"), I get

"can't activate rails (= 2.3.4, runtime) for [], already activated rails-3.0.5 for []"

I've tried installing the older version of Rails via "gem install rails -v2.3.4". Error doesn't change.

I've tried to convince Redmine to use the newer version by editing config/environment.rb to say "RAILS_GEM_VERSION = '3.0.5'". Error doesn't change.

Thoughts?

asked 26 Mar '11, 05:03

Ron Craswell
11
accept rate: 0%

Have you tried doing the Redmine installation using an older version of the Rails app installed in the Control Panel (say, Rails 2.3.5)? If not, you should give it a try.

Alternatively, you can try removing/renaming the current Rails gem directory and install the older version.

(26 Mar '11, 05:10) tie
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×108
×46

question asked: 26 Mar '11, 05:03

question was seen: 2,347 times

last updated: 26 Mar '11, 05:10

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM