WebFaction
Community site: login faq

I ssh into webfaction quite a lot to edit files, and when I do, I use the bash shell. I'd like to get it to stop beeping at me when I tab to auto-complete, and there are 0 or >1 results.

I've tried

set bell-style none
set bell-style off

inside of ~/.inputrc (not both at the same time), and then running

source ~/.inputrc

but that doesn't seem to solve the problem.

I would prefer if instead, the shell would flash briefly. I've got my Mac Terminal.app (which runs bash) to do that with the same method, but haven't got the webfaction bash to follow suit.

Ideally, I'd like this behaviour inside of bash, and also inside of shells managed by screen (which I haven't started to try out yet).

asked 31 Mar '11, 18:02

petemounce
526
accept rate: 0%


I'm using Terminal Version 2.1.1 (273) on my Mac. If I go into Terminal prefs > settings > advanced for my default profile and set the bell to "Visual bell", that setting is used when I log into a WebFaction SSH session from my terminal; that is, I get a flash for the bell.

In screen, it initially uses the "Wuff ---- Wuff!!" message to indicate a bell. If I toggle the bell to audible by hitting CTRL-A CTRL-G in screen, then I get the flash just as I do when I'm not in screen. So, it looks like screen uses it's own visual bell by default, and in audible mode it sends a regular bell character to your terminal, which it then interprets according to your own terminal settings. I think you would use "vbell off" in .screenrc to set that by default.

This is all with no special settings in .inputrc or .bashrc on my WF server, so I don't think you need to do anything on the WF side to get the effect that you want in bash.

permanent link

answered 31 Mar '11, 18:39

seanf
12.2k42136
accept rate: 37%

edited 31 Mar '11, 18:41

So I've now set "vbell off" inside of .screenrc; that does what I want. However, in bare WF shell, I still get beeps. I don't locally; I've turned them off (visual bell instead of audible one).

(31 Mar '11, 19:26) petemounce

Got any bell-related cruft in your local and remote dotfiles?

(31 Mar '11, 19:30) seanf

Ah - I did have my local .inputrc setting bell off. Removing that, killing terminal, and ssh'ing back to WF seems to have removed the issue. Thanks :-)

(02 Apr '11, 07:12) petemounce
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×3
×3
×1
×1
×1

question asked: 31 Mar '11, 18:02

question was seen: 4,437 times

last updated: 02 Apr '11, 07:12

                              
WEBFACTION
REACH US
SUPPORT
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM