WebFaction
Community site: login faq

I am running several installations of self-deployed wordpress, and they are sharing a common theme.

However, after making some changes to the theme via ssh on 30th March, the stylesheet served by nginx do not get updated. For example, this stylesheet at http://cslai.coolsilon.com/wp-content/themes/simply-kite/styles/widget.css

Age:432332
Connection:Keep-Alive
Content-Encoding:gzip
Content-Type:text/css
Date:Wed, 30 Mar 2011 06:17:44 GMT
ETag:"9d1806d-1ffb-49c745b417b00"
Last-Modified:Thu, 17 Feb 2011 06:17:48 GMT
Server:nginx

and just being curious, why is my wordpress site served by nginx?

Cache-Control:no-cache, must-revalidate, max-age=0
Connection:Keep-Alive
Content-Encoding:gzip
Content-Type:text/html; charset=UTF-8
Date:Mon, 04 Apr 2011 06:24:31 GMT
Expires:Wed, 11 Jan 1984 05:00:00 GMT
Last-Modified:Mon, 04 Apr 2011 06:24:31 GMT
Link:<http://wp.me/dupD>; rel=shortlink
Pragma:no-cache
Server:nginx
Set-Cookie:bb2_screener_=1301898270+203.217.128.10+203.217.128.10; path=/
Transfer-Encoding:chunked
X-Pingback:http://cslai.coolsilon.com/xmlrpc.php
X-Powered-By:PHP/5.2.11

asked 04 Apr '11, 01:26

Jeffrey04
736
accept rate: 0%

edited 04 Apr '11, 01:27

Hi,

Can you check again since I seem to be getting the correct headers using Chromium:

Connection:keep-alive
Content-Encoding:gzip
Content-Type:text/css
Date:Mon, 04 Apr 2011 06:32:13 GMT
ETag:"9d18852-1fc2-49fadd2860640"
Last-Modified:Wed, 30 Mar 2011 07:06:57 GMT
Server:nginx
Transfer-Encoding:chunked

Nginx is our frontend server so every request and response is proxied through from Nginx to Apache and vice versa.

Hope that helps!

(04 Apr '11, 01:36) neeravk

tried on both chrome dev 12.0.712.0 and firefox 4, but getting the similar headers :/ (used incognito on chrome too, but doesn't really solve the problem)

(04 Apr '11, 03:43) Jeffrey04
# curl -I http://cslai.coolsilon.com/wp-content/themes/simply-kite/styles/widget.css
HTTP/1.1 200 OK
Server: nginx
Date: Mon, 04 Apr 2011 08:50:45 GMT
Content-Type: text/css
Connection: keep-alive
Last-Modified: Wed, 30 Mar 2011 07:06:57 GMT
ETag: "9d18852-1fc2-49fadd2860640"
Accept-Ranges: bytes
Content-Length: 8130

We tested it on a terminal too. Do you have a direct connection or you use a proxy server to access the internet, since that seems to be the only explanation for this.

(04 Apr '11, 03:52) neeravk

argh, probably caused by the proxy (accessing via university network) :/ thanks for the help

(04 Apr '11, 23:35) Jeffrey04
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×242
×185

question asked: 04 Apr '11, 01:26

question was seen: 2,844 times

last updated: 04 Apr '11, 23:35

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2016 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM