WebFaction
Community site: login faq

Hi,

I need to run xvfb with my apache instance, I do it in apache/bin/start and apache/bin/stop. I found if the webfaction down, I will get 502 bad gateway message, but after some minutes, apache will be restarted again. Now, xvfb won't be run.

How do I make it run with apache reload after 502???

And..., I think this problem (502) happened too many times... It will break my service for a while usually few minutes. How do I relief this problem?

Thank you.

asked 28 Apr '11, 03:42

bear330
145
accept rate: 0%


The 502 Error is a sign that your Apache isn't running, so this is the real problem that you should be looking at. I guess the problem disappears in a few minutes vecause the Apache server is then properly started by the corresponding cron jobs (you can see the cron jobs by running 'crontab -l').

permanent link

answered 28 Apr '11, 03:55

tie
1.4k13
accept rate: 44%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×225
×21
×3
×1

question asked: 28 Apr '11, 03:42

question was seen: 3,320 times

last updated: 28 Apr '11, 03:55

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM