WebFaction
Community site: login faq

I am preparing to move my wife's domain over to webfaction but, before I do, I need to ensure the new home can do everything the old home can do. So far so good, however I have hit a snag with email.

She will require a catch-all wildcard (I know, I know) with a list of "anything sent to these specific users can jump off a cliff" addresses.

I have pulled together bits and pieces from various webfaction forum posts and docs, but my testing is not producing the results I would expect.

If I try something simple like this, I receive the email but it does not sort into the specified folder:

:0:
* ^To:test1@mydomain.com
.Test1/

I have also noticed that the folder name appears to be case sensitive. If I try '.test1' the email bounces back.

If I try getting fancy and introduce variables, such as suggested in this post, my messages go into a black hole and they're never seen again.

MAILDIR=$HOME/Maildir
DEFAULT=$HOME/Maildir

:0:
* ^To:test1@mydomain.com
$MAILDIR/.Test1/

Lastly, when I try to test my array of "jump off a cliff" usernames, the emails bounce back:

:0:
*^To:(test1|test2)@mydomain.com
/dev/null

Any tips would be appreciated. I am operating under the assumption that the folder names I specify above are to match the folders I create in my mailbox through the webmail interface.

asked 21 May '11, 15:30

Kyle
4113
accept rate: 0%


I believe I've answered all my own questions now. It took some effort to find a good procmail tutorial to set me straight. For any other newbs, I recommend reading through this tutorial, it's good stuff.

The below settings are now all doing exactly what I want.

:0:
^To:.test1@mydomain.com
.test1/

Note the escaped period. Durr. 'test1' is a folder I made through the webmail client.

:0:
^To:.(test2|test3)@mydomain.com
.test3/

Same as the first example but with some tighter regex and cleaned up spacing. Emails to either test2 or test3 both end up in the test3 folder.

:0:
^To:.test4@mydomain.com
! mygmail@gmail.com

Emails to test4 are forwarding to my gmail, just like I want. Seems I had to ensure there was a space between the exclamation and the email address.

:0
^To:.test5@mydomain.com
/dev/null

Never saw emails sent to this address, which is what I wanted. I'll be applying my second example here to flesh out her full list of rejected TO: addresses.

permanent link

answered 21 May '11, 16:43

Kyle
4113
accept rate: 0%

That is awesome - thanks for the tutorial link!

(21 May '11, 16:57) maryh
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×17
×1

question asked: 21 May '11, 15:30

question was seen: 4,997 times

last updated: 21 May '11, 16:57

                              
WEBFACTION
REACH US
SUPPORT
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM