WebFaction
Community site: login faq

I have a blog @ http://nexus.sc2mx.com/ that I just created. I also created an upload folder under /home/romri/webapps/nexus/wp-content/uploads and set it's permissions to 755.

If I upload manually via FTP and then link to the file directly, it works, but when I try to upload files from the Wordpress Control Panel, I get: "Add media files from your computer HTTP error."

I need to get that working because I will be handing over the blog to someone else and I don't want to give him/her direct access to my server files.

I googled the error but I didn't find a solution.

asked 19 Jun '11, 02:39

RommelTJ's gravatar image

RommelTJ
7135
accept rate: 0%

Do the logs show more info? They are located in ~/logs/frontend/

(19 Jun '11, 02:46) johns ♦♦ johns's gravatar image
[Sun Jun 19 17:18:27 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/favicon.ico
[Sun Jun 19 17:18:30 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/favicon.ico
[Sun Jun 19 17:18:36 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/favicon.ico
[Sun Jun 19 17:18:42 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/favicon.ico
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:18:45 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/favicon.ico
[Sun Jun 19 17:18:49 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/favicon.ico
[Sun Jun 19 17:18:49 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:, referer: http://nexus.sc2mx.com/wp-includes/js/swfupload/swfupload.swf?preventswfcaching=1308521928945
[Sun Jun 19 17:18:57 2011] [warn] [client 201.170.35.152] Not GET request: 2.
[Sun Jun 19 17:18:57 2011] [error] [client 201.170.35.152] File does not exist: /home/romri/webapps/nexus/wp-admin/http:
[Sun Jun 19 17:19:45 2011] [warn] [client 201.170.35.152] Not GET request: 2., referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:20:45 2011] [warn] [client 201.170.35.152] Not GET request: 2., referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:21:45 2011] [warn] [client 201.170.35.152] Not GET request: 2., referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
[Sun Jun 19 17:22:45 2011] [warn] [client 201.170.35.152] Not GET request: 2., referer: http://nexus.sc2mx.com/wp-admin/post.php?post=1&action=edit
(19 Jun '11, 17:24) RommelTJ RommelTJ's gravatar image

See below.

(19 Jun '11, 17:24) RommelTJ RommelTJ's gravatar image

That "http:" bit looked suspicious, so I checked your siteurl and home settings in your wp_options database table. They were both set to use "http:" instead of "http://nexus.sc2mx.com", so I set them to the correct value for you.

I think that should fix the problem - if it doesn't, then please open a support ticket and we'll try to take a closer look.

permanent link

answered 19 Jun '11, 17:44

seanf's gravatar image

seanf ♦♦
11.5k21333
accept rate: 37%

Hi Sean. That seems to work. Thank you.

(20 Jun '11, 14:55) RommelTJ RommelTJ's gravatar image

You're very welcome!

(20 Jun '11, 14:58) seanf ♦♦ seanf's gravatar image

Just wanted to mention that I had the same issue from a fresh WP install on webfaction. There must be something funny going on with the default database that's put in.

(05 Jan '13, 19:58) haz haz's gravatar image

Our control panel edits the site_url when you create a new website record and tried to fetch the site_url from that, if it fails than this happens and it has to be reset. It does not appear to be happening to all WordPress installs currently.

(05 Jan '13, 21:11) johns ♦♦ johns's gravatar image

Hi there -- I'm having a similar problem with my uploads on a site I'm working on at dubro.webfaction.com . Uploads were not failing last week, but are now failing occasionally. I wonder if it has to do with having changed the site URL through the WP admin settings -- was the database not updated, perhaps? And what will this mean when I change the site URL again (to a different domain that I own and am currently running a different application on) when I go live in a few days? But then why would I sometimes be able to upload images if this setting was incorrect? Is there a size limit other than the Wordpress-imposed 20MB limit? The photos in question are around 3-5mb, as this website needs high-quality photos.

Update: It looks like it's just happening for files above 2mb. Why would this be happening if the WP setting is set to a max of 20mb?

permanent link

answered 29 Dec '16, 05:29

krears's gravatar image

krears
112
accept rate: 0%

edited 29 Dec '16, 05:44

Your home and site URLs look okay. The upload_max_filesize and post_max_size are both set to 20MB, so that should not be an issue.

You can try to increase the max_execution_time PHP setting with a php.ini file as described here. If this does not help, please post a support ticket, so that we can look into this further.

(29 Dec '16, 07:46) dimitari dimitari's gravatar image
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×230
×106
×25

question asked: 19 Jun '11, 02:39

question was seen: 18,236 times

last updated: 29 Dec '16, 07:46

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2016 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM