WebFaction
Community site: login faq

Edit : thanks , i found a solution.

Hello, I did create an application under (Domains / websites => Applications) And i did create a SSH user (Account => SSH/sftp Users) when i log in whit the user & pass into SHELL and i do "cd /home/<user>/webapps/" Or "cd ~/webapps" it says "/home/<user>/webapps: No such file or directory" So how can i do a user that have the webapps folder inside ?

asked 03 Aug '11, 17:16

arcticoutlet
112
accept rate: 0%

edited 03 Aug '11, 17:20


Glad you found a solution.

permanent link

answered 03 Aug '11, 17:50

johns
5.4k312
accept rate: 23%

It would be nice if you shared your solution.

permanent link

answered 09 Jun '12, 00:38

Chaga
11
accept rate: 0%

The <user> in the above solution has to be replaced the main account under which the new SSH user has been created, you also need to grant the new user access by following:

http://docs.webfaction.com/software/general.html?highlight=grant#granting-access-to-specific-users

Is this the problem you are facing too?

(09 Jun '12, 00:45) neeravk

Thanks neeravk for pointing me to this documentation as it's possibly a permissions issue for me, but quite honestly I'm not sure if there's even a problem, because I commented below on how I'm able to navigate and open the files I want (I also use FireFTP to do this --what a great program for Mozilla). I'm just going to have to dig deeper into the documentation until I'm satisfied I understand it --not to mention CLI stuff in general, and getting really good with VIM:)

(09 Jun '12, 01:46) Chaga

I was having problems getting to my settings.php in my drupal app because the putty terminal kept saying drup: No such file or directory. So I used the cd command on the various files and folders until I finally could nano settings.php. I think there should be a better way but at least I got to the file I wanted. This website helped me under the "Where am I, what do I do, and how do I move around?" section: http://giellatekno.uit.no/doc/tools/docu-unix.html

permanent link

answered 09 Jun '12, 01:03

Chaga
11
accept rate: 0%

edited 09 Jun '12, 01:05

Ok, all the apps are installed in ~/webapps/&ltreplace-app-name>.

So, you just need to do: nano ~/webapps/<drupal-app>/sites/default/settings.php to edit the file.

(09 Jun '12, 03:05) neeravk

Thanks again neeravk: nano ~/webapps/<drupal-app>/sites/default/settings.php is the easier solution I was looking for.

(09 Jun '12, 04:15) Chaga
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×103
×57
×24
×16

question asked: 03 Aug '11, 17:16

question was seen: 6,176 times

last updated: 09 Jun '12, 04:15

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM