WebFaction
Community site: login faq

Just trying to install redmine, but can't seem to get it to run:

2011/08/11 03:45:01 [emerg] 2417#0: bind() to 0.0.0.0:10250 failed (98: Address already in use)
2011/08/11 03:45:01 [emerg] 2417#0: bind() to 0.0.0.0:10250 failed (98: Address already in use)
2011/08/11 03:45:01 [emerg] 2417#0: bind() to 0.0.0.0:10250 failed (98: Address already in use)
2011/08/11 03:45:01 [emerg] 2417#0: still could not bind()
2011/08/11 03:50:40 [emerg] 4272#0: bind() to 0.0.0.0:10250 failed (98: Address already in use)
2011/08/11 03:50:40 [emerg] 4272#0: bind() to 0.0.0.0:10250 failed (98: Address already in use)
2011/08/11 03:50:40 [emerg] 4272#0: bind() to 0.0.0.0:10250 failed (98: Address already in use)
2011/08/11 03:50:40 [emerg] 4272#0: bind() to 0.0.0.0:10250 failed (98: Address already in use)
2011/08/11 03:50:40 [emerg] 4272#0: bind() to 0.0.0.0:10250 failed (98: Address already in use)
2011/08/11 03:50:40 [emerg] 4272#0: still could not bind()

Followed these almost exactly (had to upgrade rake though): http://docs.webfaction.com/software/redmine.html

Not really sure what's going on.

Followed these steps, but they were no help: http://forum.webfaction.com/viewtopic.php?pid=19121#p19121

asked 11 Aug '11, 03:54

Brian D
335
accept rate: 0%

edited 11 Aug '11, 03:56

Hi,

You first need to stop nginx that is already running on that port.

You can do it using ~/webapps/<rails-app>/bin/stop

Hope that helps!

(11 Aug '11, 04:13) neeravk

I've done that, but it just keeps spitting out the same error in the logs.

(11 Aug '11, 09:34) Brian D

D'oh!! It was simply because I enabled HTTPS and was visiting the page on HTTP. It works fine.

(11 Aug '11, 09:38) Brian D
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×186
×81
×46

question asked: 11 Aug '11, 03:54

question was seen: 3,091 times

last updated: 11 Aug '11, 09:38

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM