WebFaction
Community site: login faq

My Django event app has worked fine on Webfaction in the past, and it still works fine locally, but now when I add a new event+occurrences on the live site, I get a 500 error. Looking in the logs/user error log, I see this:

[Sat Aug 20 08:38:35 2011] [error] server reached MaxClients setting, consider raising the MaxClients setting

The only other thing in the log file is SIGTERM when I restarted Apache. Normally when Django crashes I see a traceback. Again, this version of the site correctly adds a new event and its associated occurrences on my local machine, just not on the Webfaction live site.

Googling the MaxClients setting, I see that it is the "maximum number of connections that will be processed simultaneously". That shouldn't be a problem for my app, as I'm the only user. Normally the setting is controlled through apache conf files, but I don't see it in httpd.conf in apache2, so I'm guessing Webfaction sets it somewhere else. Can I override the setting to bump it up and see if this works? Is that a bad idea? Obviously I'd like to fix the code, but it's hard to know where to start from this. Any ideas appreciated!

Edit: I forgot to add that after a fresh Apache restart, my Django app httpd.worker processes each use about 3.6 MB memory, but following this error, one of them will shoot up to 35-40MB. It makes me wonder about a memory leak. On my local machine, the app uses about 40 MB from a fresh start of runserver, and about 47 MB after I add a new event.

asked 20 Aug '11, 20:12

sandinmyjoints
524
accept rate: 0%

edited 20 Aug '11, 20:21

Immediately after posting this, I realized I should just turn on debug on live site for a moment, and sure enough, it came down to me forgetting to load a fixture. I don't know why that didn't get printed to the error log, or why it showed the MaxClients message, though.

(20 Aug '11, 20:32) sandinmyjoints

Glad you figured it out.

(20 Aug '11, 20:35) johns

MaxClients has to do with concurrent connections to the server and can typically be dismissed as just a warning. As you state you should be getting a trackback, that is unless the error is causing the process to 'spin' or loop forever, thus it does not make it to a trackback. You might want to try enabling 'DEBUG = True' if you have not already, you may also want to try enabling the Django Debug Toolbar both live and locally and verifying the strings that are being passed around are the same in both environments,

http://docs.webfaction.com/software/django/troubleshooting.html#using-the-django-debug-toolbar

Lastly you will want to add yourself to the ADMINS and make sure your e-mail is configured to receive warnings, I have had instances where I have received only the e-mail debug info and both logs and debug mode missed the error.

permanent link

answered 20 Aug '11, 20:33

johns
5.4k312
accept rate: 23%

edited 20 Aug '11, 20:34

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×909
×225
×2

question asked: 20 Aug '11, 20:12

question was seen: 5,938 times

last updated: 20 Aug '11, 20:35

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM