WebFaction
Community site: login faq

Hi, I'm writing a little script in python and when an error accour it send me an email. If I launch the script from the server everything is ok, but I need the script on my computer and I get this error when I try to run locally

Traceback (most recent call last):
File "posta.py", line 11, in <module> s.login('ggiglio_error_reporting','b22e2164') File "/usr/lib/python2.6/smtplib.py", line 552, in login raise SMTPException("SMTP AUTH extension not supported by server.") smtplib.SMTPException: SMTP AUTH extension not supported by server.

here the script, very simple, just for testing (code from here)

from smtplib import SMTP

from_addr = 'mymail@myotherdomain.com'
to_addrs = ['myfancymail@user.webfactional.com']
msg = u"this is a test"

s = SMTP()
s.connect('smtp.webfaction.com')
s.login('mailbox name','mail box password')
s.sendmail(from_addr, to_addrs, msg)

I miss something, but what? thanks :D

asked 29 Aug '11, 10:27

Infrid
47510
accept rate: 0%

Hi,

Can you try adding the following lines after s.connect:

s.ehlo()

s.starttls()

s.ehlo()

This should ensure that a TLS connection is started to the server.

Let us know if this helps. Thanks!

(29 Aug '11, 10:43) todork

I get

Traceback (most recent call last): File "posta.py", line 14, in <module> s.starttls() File "/usr/lib/python2.6/smtplib.py", line 611, in starttls raise SMTPException("STARTTLS extension not supported by server.") smtplib.SMTPException: STARTTLS extension not supported by server.

(30 Aug '11, 03:30) Infrid

Just to double-check, are you still using "mail.webfaction.com" when running this code from your local computer?

(30 Aug '11, 03:38) todork

no, I'm using smtp.webfaction.com, the code is still the same.

(30 Aug '11, 03:44) Infrid

if it can help I'm using an account on web180...

(30 Aug '11, 03:48) Infrid

That's really weird. Could you open a ticket about this, as it would be easier to track the problem?

(30 Aug '11, 04:08) todork
showing 5 of 6 show 1 more comments

It was my net issue

permanent link

answered 31 Aug '11, 06:11

Infrid
47510
accept rate: 0%

Could you please elaborate on what you mean by "net issue"? I am having the exact same problem and am also on web180. Thanks.

(24 Sep '11, 17:03) Spike
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×337
×69
×42

question asked: 29 Aug '11, 10:27

question was seen: 6,607 times

last updated: 24 Sep '11, 17:03

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM