WebFaction
Community site: login faq

I'm trying to pull this setup off but don't seem to be having much luck. I've created 3 apps titled nginx, staging and production. The idea is to use the nginx app to serve both staging and production apps on different domains. Here's a diagram of my folder structure

<iframe src="http://pastebin.com/embed_iframe.php?i=2Ds6W9BT" style="border:none;width:100%"></iframe>

Here is the gist of my nginx.conf

<iframe src="http://pastebin.com/embed_iframe.php?i=ZmAzeuv6" style="border:none;width:100%"></iframe>

then I use a supervisord script to run nginx and uwsgi-django

here is the gist of the supervisord script I use to run everything

<iframe src="http://pastebin.com/embed_iframe.php?i=WCDg0MPR" style="border:none;width:100%"></iframe>

every time I try this and go to gruntfarm.webfactional.com/admin I get this message "UWSGI Error Python application not found" In the supervisord logs I see that the following messages which might indicate something went wrong

'import site' failed; use -v for traceback

and

added /home/gruntfarm/webapps/staging/gruntfarm/ to pythonpath.

unable to load app mountpoint=

*** no app loaded. going in full dynamic mode ***

*** uWSGI is running in multiple interpreter mode ***

spawned uWSGI worker 1 (pid: 7691, cores: 1)

Sorry for the long drawn out post. Hopefully this makes sense to somebody. Thanks.

asked 14 Sep '11, 12:07

soapisclean
1611
accept rate: 100%

Ops it seems I can't use pastebin embed codes in here :S

(14 Sep '11, 12:13) soapisclean

Ok nevermind... i fixed it... i think i wasn't activating the virtualenv correctly from the supervisord script

permanent link

answered 14 Sep '11, 12:36

soapisclean
1611
accept rate: 100%

I was also activating the uwsgi module incorrectly.. shouldve read --module gruntfarm.uwsgi

(14 Sep '11, 12:43) soapisclean
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×909
×186
×54
×17

question asked: 14 Sep '11, 12:07

question was seen: 5,289 times

last updated: 14 Sep '11, 13:12

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM