WebFaction
Community site: login faq

Hi, noob question here. My primary site jakestjohn.com has a claim on wp as the name of the wordpress app. Database was auto-named jakestjohn_wp.

Just registered a new site, drumteacherjakestjohn.com, to go on my same hosting package. The new wordpress install for this site is named wp_ dtjsj (no space after underscore in real life, that was to avoid italic formatting) and the database name was automatically shortened to jakestjohn_ wp_ dt.

So. drumteacherjakestjohn.com/wp-admin obviously does not work, nor does wp_dtjsj-admin. So I tried the link from the basic default Wordpress page that's now in place on my new domain and lo and behold, the link itself fails.

How do I access my wordpress login??

Thanks folks!

asked 14 Sep '11, 15:04

jakestjohn's gravatar image

jakestjohn
112
accept rate: 0%


Your WordPress site was configured to use the wrong domain, so I followed these steps to fix it for you: WordPress Links Point to the Wrong Domain

If you still have trouble, try clearing your browser cache and reloading the page.

Hope that helps!

permanent link

answered 14 Sep '11, 15:13

seanf's gravatar image

seanf ♦♦
12.0k21534
accept rate: 37%

edited 14 Sep '11, 15:14

Hey Sean, thanks for your help. That seems to have worked to give me access to the control panel of my new site drumteacherjakestjohn.com.

However, now my old site jakestjohn.com doesn't appear correctly (even after browser cache deletion) and THAT wp-admin page doesn't work. (I have a backup of the whole site if needed.)

Is there an inherent problem trying to run two separate Wordpress sites on two domains as part of the same Webfaction package, or am I missing something here?

Thanks again!

(15 Sep '11, 21:27) jakestjohn jakestjohn's gravatar image

Wordpress itself cannot really handle two domains for the same application; this isn't related to WebFaction.

Generally, you will want to configure your application to work on the primary domain, and then redirect other domains to this one using a redirect app.

Hope that helps!

(15 Sep '11, 21:30) ryans ♦♦ ryans's gravatar image

Oh no! I am trying to run two applications on two domains. The issue primarily was that when I created the new application for the new site, I couldn't log into it. It had nothing to do with my old site/app, that information was just included in my initial post cause I wasn't sure if it was relevant or not. Thanks Ryan!

(15 Sep '11, 21:38) jakestjohn jakestjohn's gravatar image

Just to clarify further: old site and old app worked fine. Got a new domain, and did a new install of a separate Wordpress app to be a totally different, separate site. Included the info about the old site in the initial post just because I wasn't sure if it was relevant. Sean tells me that WP was configured to use the wrong domain, and redirected it. Now the new domain works and the old one doesn't.

I am limited in my tech-knowledge, but it appears as if Sean may have misunderstood my initial problem? Otherwise I have no idea why his solution affected my old site.

Thanks,

Jake

(15 Sep '11, 21:44) jakestjohn jakestjohn's gravatar image

Yes; I think we both misunderstood. Sorry about that!

Since you have two completely separate applications and databases, the settings from one should not be affecting the other. Therefore, all you should need to do is ensure that the Wordpress internal URL is set correctly for each application.

As of this writing, your http://drumteacherjakestjohn.com/ website looks good and the /wp-admin link looks normal.

The http://jakestjohn.com/ website, on the other hand, does not, and the internal URL for all of your website links is set to "http://drumteacherjakestjohn.com/" (as can be seen from "View -> Page Source" in a web browser). So you will want to update the internal URL as Sean suggested, but only for this application and its associated database (jakestjohn_wp_wp). If this doesn't fix it, just let us know and we'll look into it further :) Hope that helps!

(15 Sep '11, 22:04) ryans ♦♦ ryans's gravatar image

Great! I was able to reset the internal URL via the functions.php method found at http://codex.wordpress.org/Changing_The_Site_URL.

Thanks for you help guys, sorry my initial question was confusing. Not sure why the internal link on the new site was messed up initially but I learned a lot and I will be able to identify that problem next time hopefully without help.

(15 Sep '11, 22:28) jakestjohn jakestjohn's gravatar image
showing 5 of 6 show 1 more comments
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×238
×39
×7
×3
×1

question asked: 14 Sep '11, 15:04

question was seen: 3,443 times

last updated: 15 Sep '11, 22:28

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2017 PARAGON INTERNET GROUP LIMITED
WEBFACTION IS A SERVICE OF PARAGON INTERNET GROUP LIMITED
REGISTERED IN ENGLAND AND WALES 7573953 - VAT REGISTRATION NUMBER 182147021
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM