WebFaction
Community site: login faq

hello there. I have the necessity to create a separate ftp/ssh access for some websites.

from my main webfaction user (verdebinario) i created a "child" ssh user (emiliano), put it in the maiin user's group and followed the steps described in http://forum.webfaction.com/viewtopic.php?id=1682

the website/application (wordpress-based) is correctly set-up as a symlink and i can correctly browse every page.

But I can't upload anything from within the wordpress web interface, nor upgrade plugins with the one-click update wordpress interface.

here's my current permission scheme for all the folders within my "child" user home:

$ ls -l /home/|grep emiliano

drwxrwx---+  4 emiliano     verdebinario  4096 Oct  2 10:13 emiliano

$ getfacl /home/emiliano/

user::rwx
user:apache:r-x
user:nginx:r-x
user:verdebinario:rwx
group::---
mask::rwx
other::---
default:user::rwx
default:user:apache:r-x
default:user:nginx:r-x
default:user:verdebinario:rwx
default:group::---
default:mask::rwx
default:other::---

what is the permission scheme to use to enable web-based upload tools? thank you.

asked 02 Oct '11, 08:28

emiliano
112
accept rate: 0%


Hi,

To upload via WordPress, you need to give apache write permissions, so you should do something like:

setfacl -R -m u:apache:rwx

permanent link

answered 02 Oct '11, 08:39

todork
1.2k4
accept rate: 34%

hm. it ain't working :(

[emiliano@webXXX emiliano]$ cd website/wp-content

[emiliano@webXXX wp-content]$ setfacl -R -m u:apache:rwx uploads/
[emiliano@webXXX wp-content]$ setfacl -R -m d:u:apache:rwx uploads/
[emiliano@web218 wp-content]$ getfacl uploads/

user::rwx
user:apache:rwx
user:nginx:r-x
user:verdebinario:rwx
group::---
group:verdebinario:rwx
mask::rwx
other::---
default:user::rwx
default:user:apache:rwx
default:user:nginx:r-x
default:user:verdebinario:rwx
default:group::---
default:group:verdebinario:rwx
default:mask::rwx
default:other::---
(02 Oct '11, 08:49) emiliano

btw, is really apache the user performing the upload?

in the apache conf file the virtual host is setup with suexec enabled.

SuexecUserGroup verdebinario verdebinario

does that mean that all the php scripts (such as the upload routine) are run with the user UID instead of apache?

(02 Oct '11, 08:56) emiliano

Hi again,

Sorry, we have two different server setups - that's why it would be better to open a ticket for this matter. Could you do that please?

(02 Oct '11, 09:24) todork

...Problem solved! my fault. :)

coming for a different server installation (i'm migrating all my websites to webfaction), wordpress "remembered" the wrong, old, absolute media storage path.

btw, the first permission scheme i posted works ok. no need to give apache write permissions.

permanent link

answered 02 Oct '11, 09:52

emiliano
112
accept rate: 0%

Glad to hear you had it resolved.

(02 Oct '11, 09:59) todork
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×64
×37
×12
×7

question asked: 02 Oct '11, 08:28

question was seen: 3,471 times

last updated: 02 Oct '11, 09:59

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM