WebFaction
Community site: login faq

About three days ago on December 28, Akismet seemed to stop detecting spam on all three of my Wordpress sites. When I login to moderate the comments, I'm greeted with the following message:

Akismet has detected a problem. A server or network problem prevented Akismet from checking < QUANTITY > comments. They have been temporarily held for moderation and will be automatically re-checked in < AMOUNT OF TIME >.

I waited until the Akismet re-checked the comments, but then the amount of time just increased. It seems that re-checking also failed. When I go to Akismet configuration, it appears that all four Akismet servers are accessible. However, the message above the API key says this:

The key below was previously validated but a connection to akismet.com can not be established at this time. Please check your server configuration.

All three Wordpress sites use the same API key.

Is anybody else encountering this issue?

asked 31 Dec '11, 13:08

dfischer
312
accept rate: 0%

Yes, I'm also seeing this issue on a site that I run for my dad. I temporarily enabled reCaptcha on his site to keep the spammers at bay.

(31 Dec '11, 16:23) devnulled

Yes, we have seen this issue on a different server and are not able to reproduce it in the test account, but we can reproduce it in the customer's account with a new WordPress app. The issue has been reported to our system administrators who will resolve it as soon as possible.

If you are receiving a lot of spam comments, it might be best to disable comments until this is resolved.

permanent link

answered 31 Dec '11, 13:18

maryh
1.3k7
accept rate: 35%

An update on this:

I was having the same problem. I raised a support ticket and after some investigation they said that the PHP version had to be upgraded from 5.2 to 5.3. When that was done, Akismet started working fine again.

permanent link

answered 08 Jan '12, 22:00

siddhi
111
accept rate: 0%

Thanks, I put in a request and I'll see what happens.

(09 Jan '12, 12:23) dfischer

This resolved the issue. Thanks

(09 Jan '12, 15:16) dfischer

Just to be sure, are you using the most recent version?

Does your version show as 'works' on the version checking utility on their site,

http://wordpress.org/extend/plugins/akismet/

permanent link

answered 02 Jan '12, 02:18

johns
5.4k312
accept rate: 23%

I am using Wordpress 3.3 and the latest AKismet (2.5.3) which the compatibility checker says works.

(04 Jan '12, 17:53) dfischer
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×244
×2

question asked: 31 Dec '11, 13:08

question was seen: 4,715 times

last updated: 26 Feb '13, 09:14

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM