WebFaction
Community site: login faq
0
1

I've setup 2 different sites with OSQA. I've created the facebook apps the exact same way. I've put the appid/secret in the external keys as instructed here. Strangely, I have 1 site that works perfectly with fb login and the other site gives this error:

"Invalid API key specified The app you are trying to access does not exist or has been disabled."

I have been over the non-working site about 10X.. comparing settings to the working site in both OSQA and in creating the FB app. Everything is exactly the same and I'm just out of ideas.

Another interesting note is that I can click the 'Add New Provider" button and it works fine in adding the new Facebook Provider number. It's only after this.. logging out and trying to login with the fb button on the front page that I am striking out.

Any idea how I might be able to further trouble shoot?

asked 31 Jan '12, 14:49

andi
5335
accept rate: 0%

Just realized the the osqa site that's not working is not showing the app api key when I view the source code of /account/signin/. It just shows var FB_API_KEY = ""; I double-checked the External Keys page and the appid is there. I restarted apache... but no difference. I tried putting them back in and saving.. and they're saving fine, but not pulling to the signin page. My working site has the key there when viewing the source code.

Any idea why this might happen?

(31 Jan '12, 18:05) andi

I've looked into this but haven't come up with any solutions. It seems like if you really do have the API key set correctly in your settings but it's not being used, you need to trace the OSQA source code with a debugger and see when that variable is accessed. You also can decorate the variable with a function to log access so that you're able to determine that it was actually used, and where.

(01 Feb '12, 02:20) ryans ♦♦

Finally!

Turns out that this was just some sort of weird caching issue within the program itself. I had tried 2 other browsers and another computer when the problem occurred to be sure it wasn't the browser caching the page and it was fine. I had restarted apache as well.

But.. I headed back just now and took a look and the api key is there! I didn't change anything so I'm not sure why it took so long to update but it now works.

Thanks for taking a look, ryans. I was headed to the function route you advised on when I realized it's now working.

permanent link

answered 01 Feb '12, 16:42

andi
5335
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×76
×40
×4

question asked: 31 Jan '12, 14:49

question was seen: 11,663 times

last updated: 01 Feb '12, 16:42

                              
WEBFACTION
REACH US
SUPPORT
LEGAL
© COPYRIGHT 2003-2021 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM