WebFaction
Community site: login faq

Hello, I'm new to django and WSGI. I'm currently having an issue with a 404 error when I try to access my application via my domain name. Typically in dev I would access it as follows localhost:8080/myapp/index/

Since I've put it on webfraction and attempted setting up my stuff I get the following error:

Page not found (404) Request Method: GET Request URL: http://www.mysite.com/ Using the URLconf defined in myurls.urls, Django tried these URL patterns, in this order: ^myapp/ The current URL, , didn't match any of these. You're seeing this error because you have DEBUG = True in your Django settings file. Change that to False, and Django will display a standard 404 page.

Any suggestions as to how I can correct this issue and get my app working properly? Thanks.

asked 14 Mar '12, 15:33

hacktorious
111
accept rate: 0%


Just had to put my app in my python path and it solved the issue.

permanent link

answered 14 Mar '12, 19:29

hacktorious
111
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×909
×108
×62
×22

question asked: 14 Mar '12, 15:33

question was seen: 4,438 times

last updated: 14 Mar '12, 19:29

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2019 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM