WebFaction
Community site: login faq

I've been working with a programmer on a site for a while, and he's going to be unavailable for a bit, so I was hoping to dupe the test version of the site to work on CSS styling in the interim.

Everything's functioning except that the CSS and images aren't showing on the new test site.

He'd put everything in two directories: foo-site and foomedia-site; I've faithfully copied over both directories into foo-test and foomedia-test, have created and linked to a new database for foo-test, and tried pointing every reference to foomedia-site in the .py files governing the foo-site to foomedia-test instead of foodmedia-site.

It probably goes without saying that foo-site and foo-test are the "meat" of the site, and foomedia-site and foomedia-test are the repositories for css, images and JavaScript.

Right now the site works -- and the database contents seem intact and fine -- but foo-test isn't linking to anything in foomedia-test. Again, I've changed all the references to foomedia-site over in all of the .py files. Can't figure out what else I need to do to get these two directories "talking."

You can probably tell that I'm a quasi-newbie at all of this.

asked 26 Mar '12, 17:28

mattshepherd
4551930
accept rate: 0%

edited 26 Mar '12, 17:29

Can you see what the URls rendered for CSS/JS in your HTML like? Have you mounted your static media to the correct locations as seen in source?

http://docs.webfaction.com/software/django/config.html#serving-django-static-media

(27 Mar '12, 05:15) neeravk

Following the link to reset the correct locations worked! Thanks!

(27 Mar '12, 17:50) mattshepherd
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×337
×19
×3
×1

question asked: 26 Mar '12, 17:28

question was seen: 2,387 times

last updated: 27 Mar '12, 17:50

                              
WEBFACTION
REACH US
SUPPORT
LEGAL
© COPYRIGHT 2003-2020 SWARMA LIMITED - WEBFACTION IS A SERVICE OF SWARMA LIMITED
REGISTERED IN ENGLAND AND WALES 5729350 - VAT REGISTRATION NUMBER 877397162
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM