WebFaction
Community site: login faq

It's quite weird. I had installed my first wordpress multi-site successfully in last month. It works like a charm serving 2 domains within 1 network correctly.

I'd like to install another wordpress multi-site for a new network which demands quite different plugins.

The issue is: root domain A.com is constantly being redirected to the second domain B.com, causing fatal redirection-loop error.

To rescue the root domain A.com, I deleted websites records of B.com in webfaction console. I deleted the domain mapping records from wordpress database and all wp_2 tables. I deleted the DNS A records of B.com from dns manager.

But the domain A.com is still being redirected to domain B.com which is now a domain with no ip or cname pointing to webfaction.

I did a tracert to A.com which showed the route to webfaction was correct. So it seems nginx or apache on webfaction server did the redirection! How to clear the redirection?

asked 12 May '12, 08:47

HowardMei's gravatar image

HowardMei
111
accept rate: 0%

update: I deleted the A.com sites configuration and recreated it again in webfaction control panel. Now A.com could be accessed normally.

(12 May '12, 09:32) HowardMei HowardMei's gravatar image

update: The root domain A.com/wp-admin is still being redirected to B.com/wp-admin

(12 May '12, 09:39) HowardMei HowardMei's gravatar image

Did you follow the instructions on WP's help page when creating your network? There are several things that could cause such problems, the rules in .htaccess being the most likely culprit. If the instructions in WP's docs don't help you resolve the problem, please open a ticket so we can take a look at your configuration and try to find the problem for you.

permanent link

answered 12 May '12, 10:44

todork's gravatar image

todork
1.2k4
accept rate: 34%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×238

question asked: 12 May '12, 08:47

question was seen: 3,881 times

last updated: 12 May '12, 10:44

WEBFACTION
REACH US
SUPPORT
AFFILIATE PROGRAM
LEGAL
© COPYRIGHT 2003-2017 PARAGON INTERNET GROUP LIMITED
WEBFACTION IS A SERVICE OF PARAGON INTERNET GROUP LIMITED
REGISTERED IN ENGLAND AND WALES 7573953 - VAT REGISTRATION NUMBER 182147021
5TH FLOOR, THE OLD VINYL FACTORY, HAYES, UB3 1HA, UNITED KINGDOM